aboutsummaryrefslogtreecommitdiffstats
path: root/community/qt5-qtwebkit
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-12-28 10:37:10 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-12-28 11:27:30 +0000
commita2c37467b932935f1fbc3ecfe0b66cf8367d75c5 (patch)
treee0dda6d652077403c21dfb239036ed4d4dd9c4bf /community/qt5-qtwebkit
parenta347a358bcff5bd7943e76d001c8f3d4b1a4524b (diff)
community/qt5-qtwebkit: fix path to QtSignalSpy
Diffstat (limited to 'community/qt5-qtwebkit')
-rw-r--r--community/qt5-qtwebkit/APKBUILD6
-rw-r--r--community/qt5-qtwebkit/qt5.12.patch26
2 files changed, 30 insertions, 2 deletions
diff --git a/community/qt5-qtwebkit/APKBUILD b/community/qt5-qtwebkit/APKBUILD
index a84935f6a9d..a75e0899627 100644
--- a/community/qt5-qtwebkit/APKBUILD
+++ b/community/qt5-qtwebkit/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=qt5-qtwebkit
pkgver=5.9.1
-pkgrel=3
+pkgrel=4
pkgdesc="Qt5 - QtWebKit components"
url="http://qt-project.org/"
arch="all"
@@ -42,6 +42,7 @@ source="http://download.qt-project.org/$_rel/qt/${pkgver%.*}/$_ver/submodules/qt
fix-rpath.patch
fix-execinfo.patch
0001-Add-ARM-64-support.patch
+ qt5.12.patch
"
builddir="$srcdir"/qtwebkit-opensource-src-$_V
@@ -84,4 +85,5 @@ sha512sums="79316ab746a230fdb290e28629d7cec5fca75119ba8868060742c682ab86490de9ff
9a62a5e7af91c44311b517608262f88b5bc607e75dc5878dd08b0a0872ec03fb7a566df0a41413f7e60beb1b9880e24f084b90c38ed50d4219ec2ad6af9bd62f pic.patch
00d59c0cdb58ae8e7cf6bc3d03f133697e74c267ccebe12238bcdc274d4c90210b82c2d8bdf0e949cd43da13a4fd8a4c35fb54a00ed5102a4ac4d23aa002d0fe fix-rpath.patch
f17c2f4b90090c8f12e4ba1f2cbd7a9f496c8de024ba6e0d55b98e5b89ab89298aff84f39e81905e0491fe6bd11544633a8b191403a866e16ed654d44cf8dc6f fix-execinfo.patch
-af5097d44f73de156ca31a5423136301dfc12ae693e20c4702bf3f1c6e16395f3912e9268582480ba3177021f37d4cae3b84d4b23eeb063fdc40f2444d3b34c8 0001-Add-ARM-64-support.patch"
+af5097d44f73de156ca31a5423136301dfc12ae693e20c4702bf3f1c6e16395f3912e9268582480ba3177021f37d4cae3b84d4b23eeb063fdc40f2444d3b34c8 0001-Add-ARM-64-support.patch
+5e056bc410892dee53825b191d227a669bba75579bdcf20a671afc063200a6dfd8348dff65f3560a3a9726c07b627be3ba9ac151b05d9bc6535da7d7669018f8 qt5.12.patch"
diff --git a/community/qt5-qtwebkit/qt5.12.patch b/community/qt5-qtwebkit/qt5.12.patch
new file mode 100644
index 00000000000..f1ca8811b71
--- /dev/null
+++ b/community/qt5-qtwebkit/qt5.12.patch
@@ -0,0 +1,26 @@
+diff --git a/Source/WebKit/qt/tests/util.h b/Source/WebKit/qt/tests/util.h
+index 4925aa4..9f834f7 100644
+--- a/Source/WebKit/qt/tests/util.h
++++ b/Source/WebKit/qt/tests/util.h
+@@ -23,7 +23,7 @@
+ #endif
+
+ #include <QEventLoop>
+-#include <QSignalSpy>
++#include <QtTest/QSignalSpy>
+ #include <QTimer>
+
+ #if !defined(TESTS_SOURCE_DIR)
+diff --git a/Source/WebKit2/UIProcess/API/qt/tests/util.h b/Source/WebKit2/UIProcess/API/qt/tests/util.h
+index 8711d5b..6bb97fa 100644
+--- a/Source/WebKit2/UIProcess/API/qt/tests/util.h
++++ b/Source/WebKit2/UIProcess/API/qt/tests/util.h
+@@ -19,7 +19,7 @@
+ // Functions and macros that really need to be in QTestLib
+
+ #include <QEventLoop>
+-#include <QSignalSpy>
++#include <QtTest/QSignalSpy>
+ #include <QTimer>
+
+ class QQuickWebView;