aboutsummaryrefslogtreecommitdiffstats
path: root/community/qt6-qtscxml/APKBUILD
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2021-05-15 15:47:25 +0200
committerBart Ribbers <bribbers@disroot.org>2021-05-15 14:22:26 +0000
commitc5e0382b9cc668b0f0aedd6650af29273a947bac (patch)
tree1a78b58ca408463c9670c8f71918ae6caa573765 /community/qt6-qtscxml/APKBUILD
parent8401b7a34cb76b3fe670bbb3f988eadb0f4d639b (diff)
community/qt6-qtscxml: move from testing
Diffstat (limited to 'community/qt6-qtscxml/APKBUILD')
-rw-r--r--community/qt6-qtscxml/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/community/qt6-qtscxml/APKBUILD b/community/qt6-qtscxml/APKBUILD
new file mode 100644
index 00000000000..4a58dd82236
--- /dev/null
+++ b/community/qt6-qtscxml/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=qt6-qtscxml
+pkgver=6.1.0
+pkgrel=0
+pkgdesc="Static and runtime integration of SCXML models into Qt6 code"
+url="https://qt.io"
+arch="all"
+license="LGPL-2.1-only AND LGPL-3.0-only AND GPL-3.0-only AND Qt-GPL-exception-1.0"
+depends_dev="
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
+ "
+makedepends="$depends_dev
+ cmake
+ perl
+ "
+subpackages="$pkgname-dev"
+options="!check" # No tests
+builddir="$srcdir/qtscxml-everywhere-src-${pkgver/_/-}"
+
+case $pkgver in
+ *_alpha*|*_beta*|*_rc*) _rel=development_releases;;
+ *) _rel=official_releases;;
+esac
+
+source="https://download.qt.io/$_rel/qt/${pkgver%.*}/${pkgver/_/-}/submodules/qtscxml-everywhere-src-${pkgver/_/-}.tar.xz"
+
+build() {
+ cmake -B build \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}
+
+sha512sums="
+89042c5f50122e2818bbb9938ff673f4dbf4aa3c8e4620999a131f577ca1dd0cfd3258c36a1ec686d0de5d67cb9e03ff219c5495e6006c1d3156371ff73c8611 qtscxml-everywhere-src-6.1.0.tar.xz
+"