aboutsummaryrefslogtreecommitdiffstats
path: root/community/rawtherapee/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-11-23 12:30:54 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-11-23 13:00:13 +0000
commit5776a8f79ee587882c867aba3f5bd34fc4dbfdc1 (patch)
tree1d679bc4ba05436e633641f5d96ff5f3b0999c43 /community/rawtherapee/APKBUILD
parent7f216e7b52efe6ca35e045b240d7f2adec6e9a99 (diff)
community/rawtherapee: fix build with sigc++ 2.5.2
Diffstat (limited to 'community/rawtherapee/APKBUILD')
-rw-r--r--community/rawtherapee/APKBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/community/rawtherapee/APKBUILD b/community/rawtherapee/APKBUILD
new file mode 100644
index 00000000000..d5c9e805eff
--- /dev/null
+++ b/community/rawtherapee/APKBUILD
@@ -0,0 +1,54 @@
+# Contributor: ScrumpyJack <scrumpyjack@st.ilet.to>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=rawtherapee
+pkgver=4.2
+pkgrel=1
+pkgdesc="RawTherapee is image processing software simular to Lightroom or Aperture"
+url="http://rawtherapee.com"
+arch="all"
+license="GPL3"
+depends=""
+depends_dev=""
+makedepends="bzip2-dev exiv2-dev expat-dev fftw-dev glib-dev gtk+2.0-dev \
+ gtk-engines-dev gtkmm-dev lcms2-dev libcanberra-dev \
+ libpng-dev libsigc++-dev tiff-dev zlib-dev cmake mercurial \
+ libiptcdata-dev libjpeg-turbo-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://rawtherapee.com/shared/source/${pkgname}-${pkgver}.tar.xz
+ sigc++.patch
+ c++11.patch
+ "
+
+_builddir=${srcdir}/${pkgname}-${pkgver}
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ export CXXFLAGS="$CXXFLAGS -std=c++11"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr || return 1
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="e6510ed56fdc35aa712b4c0f54c52ac0 rawtherapee-4.2.tar.xz
+63dc8bf5dd7468a12fba75805fb6520d sigc++.patch
+5fa63cca42b2af2cd6cddab3e8dfd786 c++11.patch"
+sha256sums="fa4c13e8842df096b19d2dabaed5a61f5f9d4547f7b4f0dc6b77f80bdec16479 rawtherapee-4.2.tar.xz
+d57361e6bdb0386ca84b4c25b7aed0b4b6659035f72178a6f8cb6f9031672c90 sigc++.patch
+9a63bd8d0c0149bf48e33441b5f0e2c163bfcd9c3204a6d353c054eb69e7bcb6 c++11.patch"
+sha512sums="feec61aeb84804cf01ff03fa9d7309f0eb3c04c43818c8397cc6f3ee762aca19484bce7594414d2141248b9740bdd4269fd86f76dcf391c61d4647fa169d48f6 rawtherapee-4.2.tar.xz
+bce6c8b1f02ff335ef10fff7decc61f21c5c8cea251fe703d9fc50616d3113f0439cd05b06aa698849f4356afa63ddf19d0a5d2f39df7ff73406a3e243cafb09 sigc++.patch
+81a403b999e5aa9e2e91445734950ac01de7daab3c21569cad78c7bb54d43e7db9340320e556d8bc3f12c4903bc66852e17306e3b73e0744d02d7c2ff32ad239 c++11.patch"