aboutsummaryrefslogtreecommitdiffstats
path: root/community/rawtherapee
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-05-04 11:41:17 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-05-04 11:41:50 +0000
commitd9ef8ec729115d79f860364e2e29381d96ebcd51 (patch)
tree714d53b81785e6b4a15099240f9ac77d783e62e5 /community/rawtherapee
parent682038d993d371b9cc6f80e61952c3ef125ece41 (diff)
community/rawtherapee: upgrade to 5.0-r1
Disable check()
Diffstat (limited to 'community/rawtherapee')
-rw-r--r--community/rawtherapee/APKBUILD31
-rw-r--r--community/rawtherapee/c++11.patch28
-rw-r--r--community/rawtherapee/gcc6.patch11
-rw-r--r--community/rawtherapee/sigc++.patch52
4 files changed, 7 insertions, 115 deletions
diff --git a/community/rawtherapee/APKBUILD b/community/rawtherapee/APKBUILD
index 7be9e086708..b097b80a4e0 100644
--- a/community/rawtherapee/APKBUILD
+++ b/community/rawtherapee/APKBUILD
@@ -1,27 +1,21 @@
# Contributor: ScrumpyJack <scrumpyjack@st.ilet.to>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=rawtherapee
-pkgver=4.2
-pkgrel=2
+pkgver=5.0.r1
+pkgrel=0
+_gtkver=2
pkgdesc="RawTherapee is image processing software simular to Lightroom or Aperture"
url="http://rawtherapee.com"
arch="x86 x86_64"
license="GPL3"
-depends=""
-depends_dev=""
makedepends="bzip2-dev exiv2-dev expat-dev fftw-dev glib-dev gtk+2.0-dev \
gtk-engines-dev gtkmm-dev lcms2-dev libcanberra-dev \
libpng-dev libsigc++-dev tiff-dev zlib-dev cmake mercurial \
libiptcdata-dev libjpeg-turbo-dev"
-install=""
+options="!check"
subpackages="$pkgname-doc"
-source="http://rawtherapee.com/shared/source/${pkgname}-${pkgver}.tar.xz
- sigc++.patch
- c++11.patch
- gcc6.patch
- "
-
-builddir=${srcdir}/${pkgname}-${pkgver}
+source="http://rawtherapee.com/shared/source/${pkgname}-${pkgver/.r/-r}-gtk$_gtkver.tar.xz"
+builddir=${srcdir}/${pkgname}-${pkgver/.r/-r}-gtk$_gtkver
build() {
mkdir -p "$builddir"/build
@@ -37,15 +31,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-md5sums="e6510ed56fdc35aa712b4c0f54c52ac0 rawtherapee-4.2.tar.xz
-63dc8bf5dd7468a12fba75805fb6520d sigc++.patch
-5fa63cca42b2af2cd6cddab3e8dfd786 c++11.patch
-acf576a2e18fb92f1249db662ec74dd8 gcc6.patch"
-sha256sums="fa4c13e8842df096b19d2dabaed5a61f5f9d4547f7b4f0dc6b77f80bdec16479 rawtherapee-4.2.tar.xz
-d57361e6bdb0386ca84b4c25b7aed0b4b6659035f72178a6f8cb6f9031672c90 sigc++.patch
-9a63bd8d0c0149bf48e33441b5f0e2c163bfcd9c3204a6d353c054eb69e7bcb6 c++11.patch
-b5c9e8fa56bc690215c0eb7e2c26de59a928fb532d5e339d35a070ae4a011815 gcc6.patch"
-sha512sums="feec61aeb84804cf01ff03fa9d7309f0eb3c04c43818c8397cc6f3ee762aca19484bce7594414d2141248b9740bdd4269fd86f76dcf391c61d4647fa169d48f6 rawtherapee-4.2.tar.xz
-bce6c8b1f02ff335ef10fff7decc61f21c5c8cea251fe703d9fc50616d3113f0439cd05b06aa698849f4356afa63ddf19d0a5d2f39df7ff73406a3e243cafb09 sigc++.patch
-81a403b999e5aa9e2e91445734950ac01de7daab3c21569cad78c7bb54d43e7db9340320e556d8bc3f12c4903bc66852e17306e3b73e0744d02d7c2ff32ad239 c++11.patch
-94f5939175cf22712c886ff7d2069f02c81a14e5ccdff73496605c837f56b6960252fa9ee7ca390990cb49382f7fbf8d242f361ed2044ef33d250796b5656e02 gcc6.patch"
+sha512sums="91ce5664371933554738282ae0f099431b29c3bd9010a85ed7bcf7895aadaae12aef61ce41dafa7b75fa382e82ae53edc231c20ade7971b6d34d5e4324138886 rawtherapee-5.0-r1-gtk2.tar.xz"
diff --git a/community/rawtherapee/c++11.patch b/community/rawtherapee/c++11.patch
deleted file mode 100644
index 86a6ff0717c..00000000000
--- a/community/rawtherapee/c++11.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From c6620b415db72cbdf8833476a21af5190e15fa22 Mon Sep 17 00:00:00 2001
-From: Marcin Bajor <marcin.bajor@gmail.com>
-Date: Wed, 14 Oct 2015 10:51:27 +0200
-Subject: [PATCH] Fix for build with C++11 flags
-
----
- rtengine/dcraw.cc | 8 ++++----
- 1 file changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/rtengine/dcraw.cc b/rtengine/dcraw.cc
-index add5b52..8e0a36d 100644
---- a/rtengine/dcraw.cc
-+++ b/rtengine/dcraw.cc
-@@ -136,10 +136,10 @@ const float d65_white[3] = { 0.950456, 1, 1.088754 };
-
- #define SQR(x) rtengine::SQR(x)
- #define ABS(x) (((int)(x) ^ ((int)(x) >> 31)) - ((int)(x) >> 31))
--#define MIN(a,b) rtengine::min(a,static_cast<typeof(a)>(b))
--#define MAX(a,b) rtengine::max(a,static_cast<typeof(a)>(b))
--#define LIM(x,min,max) rtengine::LIM(x,static_cast<typeof(x)>(min),static_cast<typeof(x)>(max))
--#define ULIM(x,y,z) rtengine::ULIM(x,static_cast<typeof(x)>(y),static_cast<typeof(x)>(z))
-+#define MIN(a,b) rtengine::min(a,static_cast<__typeof__(a)>(b))
-+#define MAX(a,b) rtengine::max(a,static_cast<__typeof__(a)>(b))
-+#define LIM(x,min,max) rtengine::LIM(x,static_cast<__typeof__(x)>(min),static_cast<__typeof__(x)>(max))
-+#define ULIM(x,y,z) rtengine::ULIM(x,static_cast<__typeof__(x)>(y),static_cast<__typeof__(x)>(z))
- #define CLIP(x) rtengine::CLIP(x)
- #define SWAP(a,b) { a=a+b; b=a-b; a=a-b; }
-
diff --git a/community/rawtherapee/gcc6.patch b/community/rawtherapee/gcc6.patch
deleted file mode 100644
index b4ee6126a6f..00000000000
--- a/community/rawtherapee/gcc6.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./rtexif/rtexif.h.orig
-+++ ./rtexif/rtexif.h
-@@ -410,7 +410,7 @@
- else
- lensAperture = exp( log(a1)+(log(a2)-log(a1))/(log(f2)-log(f1))*(log(focalLength)-log(f1)) );
-
-- dif = abs(lensAperture - maxApertureAtFocal);
-+ dif = std::abs(lensAperture - maxApertureAtFocal);
- }else
- dif = 0;
- if( dif < deltaMin ){
diff --git a/community/rawtherapee/sigc++.patch b/community/rawtherapee/sigc++.patch
deleted file mode 100644
index eeeefb733df..00000000000
--- a/community/rawtherapee/sigc++.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-diff --git a/rtgui/adjuster.cc b/rtgui/adjuster.cc
-index f73dd8a..a7a069c 100644
---- a/rtgui/adjuster.cc
-+++ b/rtgui/adjuster.cc
-@@ -17,7 +17,7 @@
- * along with RawTherapee. If not, see <http://www.gnu.org/licenses/>.
- */
- #include "adjuster.h"
--#include <sigc++/class_slot.h>
-+#include <sigc++/slot.h>
- #include <cmath>
- #include "multilangmgr.h"
- #include "../rtengine/rtengine.h"
-diff --git a/rtgui/preferences.cc b/rtgui/preferences.cc
-index 134c0d7..8ce1808 100644
---- a/rtgui/preferences.cc
-+++ b/rtgui/preferences.cc
-@@ -16,7 +16,7 @@
- * You should have received a copy of the GNU General Public License
- * along with RawTherapee. If not, see <http://www.gnu.org/licenses/>.
- */
--#include <sigc++/class_slot.h>
-+#include <sigc++/slot.h>
- #include "preferences.h"
- #include "multilangmgr.h"
- #include "splash.h"
-diff --git a/rtgui/thresholdadjuster.cc b/rtgui/thresholdadjuster.cc
-index 6b41329..19cde25 100644
---- a/rtgui/thresholdadjuster.cc
-+++ b/rtgui/thresholdadjuster.cc
-@@ -17,7 +17,7 @@
- * along with RawTherapee. If not, see <http://www.gnu.org/licenses/>.
- */
- #include "thresholdadjuster.h"
--#include <sigc++/class_slot.h>
-+#include <sigc++/slot.h>
- #include <cmath>
- #include "multilangmgr.h"
- #include "../rtengine/rtengine.h"
-diff --git a/rtgui/tonecurve.cc b/rtgui/tonecurve.cc
-index 2e439e1..5f14200 100644
---- a/rtgui/tonecurve.cc
-+++ b/rtgui/tonecurve.cc
-@@ -18,7 +18,7 @@
- */
- #include "tonecurve.h"
- #include "adjuster.h"
--#include <sigc++/class_slot.h>
-+#include <sigc++/slot.h>
- #include <iomanip>
- #include "ppversion.h"
- #include "edit.h"