aboutsummaryrefslogtreecommitdiffstats
path: root/community/redland
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-05-18 08:10:17 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-05-18 12:52:04 +0000
commit06f179a74f84de88687dd1cf38c7b97a01e07346 (patch)
treec84c845f9cfb514128d5a46febaa7a4be4a34b28 /community/redland
parent7f31fea2f9a43b6a22e377fc8a662471e245fc36 (diff)
community/redland: moved from main
Diffstat (limited to 'community/redland')
-rw-r--r--community/redland/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/community/redland/APKBUILD b/community/redland/APKBUILD
new file mode 100644
index 00000000000..3a8daa74db7
--- /dev/null
+++ b/community/redland/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=redland
+pkgver=1.0.17
+pkgrel=0
+pkgdesc="high-level RDF library"
+url="http://www.librdf.org/"
+arch="all"
+license="GPL"
+depends=
+depends_dev="raptor2-dev rasqal-dev sqlite-dev"
+makedepends="$depends_dev perl"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://download.librdf.org/source/redland-$pkgver.tar.gz"
+
+_builddir="$srcdir"/redland-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ LIBS="-lm" ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="e5be03eda13ef68aabab6e42aa67715e redland-1.0.17.tar.gz"
+sha256sums="de1847f7b59021c16bdc72abb4d8e2d9187cd6124d69156f3326dd34ee043681 redland-1.0.17.tar.gz"
+sha512sums="363323ffc9e75d4f0e3a3b40952f6241fd0d8b9f46bfd4dd86cf0a5162de35257a8b70ce408a6083c03ba7c388982231a3774e5e9024b262ebb02968f778b850 redland-1.0.17.tar.gz"