aboutsummaryrefslogtreecommitdiffstats
path: root/community/roundcubemail-mobile
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2019-01-26 16:28:57 +0100
committerJakub Jirutka <jakub@jirutka.cz>2019-01-26 16:28:57 +0100
commit039f225a892fed6678d43a17f093423990753719 (patch)
tree3b57cf7248284a14b9d4a1ed6d226263447c16e5 /community/roundcubemail-mobile
parent56fbe2e7518dc89fc065fd02c24823ee1e51a888 (diff)
community/roundcubemail-mobile: move from testing
Diffstat (limited to 'community/roundcubemail-mobile')
-rw-r--r--community/roundcubemail-mobile/APKBUILD74
1 files changed, 74 insertions, 0 deletions
diff --git a/community/roundcubemail-mobile/APKBUILD b/community/roundcubemail-mobile/APKBUILD
new file mode 100644
index 00000000000..4fc39d96ba7
--- /dev/null
+++ b/community/roundcubemail-mobile/APKBUILD
@@ -0,0 +1,74 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+
+pkgname=roundcube-mobile
+# NOTE: These 3 plugins/skins forms one product, they are not used separately
+# anywhere, thus I put them together into single abuild.
+_pkgname_plugin=Roundcube-Plugin-Mobile
+_pkgname_skin=Roundcube-Skin-Melanie2-Larry-Mobile
+_pkgname_jquery=Roundcube-Plugin-JQuery-Mobile
+pkgver=0.4.8
+pkgrel=0
+_pkgver_jquery=1.1
+pkgdesc="Mobile plugin and skin for Roundcube by Melanie2"
+url="https://plugins.roundcube.net/packages/melanie2/mobile"
+arch="noarch"
+license="GPL-3.0-or-later CC-3.0-BY-SA"
+depends="roundcubemail"
+pkggroups="roundcube"
+options="!check" # no tests provided
+subpackages="
+ $pkgname-calendar:_plugin
+ $pkgname-enigma:_plugin
+ $pkgname-managesieve:_plugin
+ "
+source="https://github.com/messagerie-melanie2/$_pkgname_plugin/archive/v$pkgver/$_pkgname_plugin-$pkgver.tar.gz
+ https://github.com/messagerie-melanie2/$_pkgname_skin/archive/v$pkgver/$_pkgname_skin-$pkgver.tar.gz
+ https://github.com/messagerie-melanie2/$_pkgname_jquery/archive/v$_pkgver_jquery/$_pkgname_jquery-$_pkgver_jquery.tar.gz
+ "
+
+_confdir="etc/roundcube/plugins"
+_rcdir="usr/share/webapps/roundcube"
+
+prepare() {
+ cd "$srcdir"
+
+ find . -type f -exec chmod -x {} +
+ rm -f */.gitignore */composer.json */package.xml */LICENCE */README.*
+}
+
+package() {
+ local plugdir="$pkgdir/$_rcdir/plugins"
+ local skindir="$pkgdir/$_rcdir/skins"
+
+ cd "$srcdir"
+
+ mkdir -p "$plugdir"
+ cp -r "$_pkgname_jquery-$_pkgver_jquery" "$plugdir"/jquery_mobile
+ cp -r "$_pkgname_plugin-$pkgver" "$plugdir"/mobile
+ rm -R "$plugdir"/mobile/plugins
+
+ mkdir -p "$skindir"
+ cp -r "$_pkgname_skin-$pkgver" "$skindir"/melanie2_larry_mobile
+
+ install -m 644 -g roundcube -D "$plugdir"/mobile/config.inc.php.dist \
+ "$pkgdir"/$_confdir/mobile.inc.php
+ ln -s /$_confdir/mobile.inc.php "$plugdir"/mobile/config.inc.php
+}
+
+_plugin() {
+ local subname="${subpkgname#$pkgname-}"
+ local plugdir="$subpkgdir/$_rcdir/plugins"
+
+ pkgdesc="$pkgdesc (skin for $subname)"
+ install_if="$pkgname=$pkgver-r$pkgrel roundcubemail-$subname"
+
+ cd "$srcdir/$_pkgname_plugin-$pkgver"
+
+ mkdir -p "$plugdir"/$subname
+ cp -r plugins/$subname/skins "$plugdir"/$subname/
+}
+
+sha512sums="e59543c30bd89527468b0a17a734f8556f92c67f0a41943ebce0ec2e7ae7fe424d03273c5bc963f96bb5188301e813e2ae432c823de63f379d1518e58a96f291 Roundcube-Plugin-Mobile-0.4.8.tar.gz
+7b81fd33d46f3422d58852b26c4d74628a780abc0ffe260cc3b853f18a1aa8ae0560ca88e7a5a48f21e9e8c212f16bf8b841a3b89fc4fc36004c9672867c2c8d Roundcube-Skin-Melanie2-Larry-Mobile-0.4.8.tar.gz
+ec1985ac8148ed7e652659b9481501a686ae7476149fcace6074edfc20d599d252b4795ce18580b5b4291feb58761c19d9f284885828ca3391abe4ba346ecca9 Roundcube-Plugin-JQuery-Mobile-1.1.tar.gz"