aboutsummaryrefslogtreecommitdiffstats
path: root/community/rspamd/APKBUILD
diff options
context:
space:
mode:
authorDuncan Bellamy <dunk@denkimushi.com>2020-03-08 14:12:40 +0000
committerRasmus Thomsen <oss@cogitri.dev>2020-03-08 22:26:23 +0100
commit49dbb2b2a0ea78dfb82412161ce7ce4039b9ed40 (patch)
treeecf55c6fcb22b80b35a4396d0cfc0ab183ccfe79 /community/rspamd/APKBUILD
parent08456ff13da089f86a862152eeb1c26978a673b5 (diff)
community/rspamd: add libs sub package
Add libs sub package so the client rspamc can be installed on a seperate machine without the rspamd base package
Diffstat (limited to 'community/rspamd/APKBUILD')
-rw-r--r--community/rspamd/APKBUILD11
1 files changed, 10 insertions, 1 deletions
diff --git a/community/rspamd/APKBUILD b/community/rspamd/APKBUILD
index 940e7ed87e0..e6910fd8342 100644
--- a/community/rspamd/APKBUILD
+++ b/community/rspamd/APKBUILD
@@ -3,9 +3,10 @@
# Contributor: Nathan Angelacos <nangel@alpinelinux.org>
# Contributor: TBK <alpine@jjtc.eu>
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Contributor: Duncan Bellamy <dunk@denkimushi.com>
pkgname=rspamd
pkgver=2.4
-pkgrel=0
+pkgrel=1
pkgdesc="Fast, free and open-source spam filtering system"
url="https://rspamd.com/"
arch="all"
@@ -34,6 +35,7 @@ install="$pkgname.pre-install $pkgname.post-upgrade"
subpackages="
$pkgname-doc
$pkgname-client
+ $pkgname-libs
$pkgname-utils::noarch
$pkgname-controller::noarch
$pkgname-fuzzy::noarch
@@ -110,6 +112,13 @@ client() {
mv ./usr/bin/rspamc-$pkgver "$subpkgdir"/usr/bin/rspamc
}
+libs() {
+ pkgdesc="$pkgdesc (libraries)"
+
+ cd "$pkgdir"
+ amove usr/lib/$pkgname/*.so
+}
+
utils() {
pkgdesc="$pkgdesc (utilities)"
depends="perl"