aboutsummaryrefslogtreecommitdiffstats
path: root/community/ruby-ox/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-02-18 19:19:05 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-02-18 19:19:49 +0100
commit8d152e11e7d6dc7bcc58720f34374f20a4234a49 (patch)
treea8903808dc202b5fb6dfcfe3ff2c01fc87099101 /community/ruby-ox/APKBUILD
parent5c28790c03759f6fcbca17b41315f634dd95d190 (diff)
community/ruby-ox: fix install location of ox.so
Diffstat (limited to 'community/ruby-ox/APKBUILD')
-rw-r--r--community/ruby-ox/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/community/ruby-ox/APKBUILD b/community/ruby-ox/APKBUILD
index c644c0c7503..86d0f079dbd 100644
--- a/community/ruby-ox/APKBUILD
+++ b/community/ruby-ox/APKBUILD
@@ -3,7 +3,7 @@
pkgname=ruby-ox
_gemname=${pkgname#ruby-}
pkgver=2.8.2
-pkgrel=1
+pkgrel=2
pkgdesc="A fast XML parser and object serializer for Ruby"
url="https://github.com/ohler55/ox"
arch="all"
@@ -26,8 +26,12 @@ build() {
--verbose \
$_gemname
+ cd dist/extensions/*/*/$_gemname-*/
+
+ # ox expects ox.so to be in ox/ subdirectory, but does not install it here.
+ mkdir ox && mv *.so ox/
# Needed for tests.
- cp -l dist/extensions/*/*/$_gemname-*/*.so ext/$_gemname/
+ cp -l ox/*.so "$builddir"/ext/$_gemname/
}
check() {