aboutsummaryrefslogtreecommitdiffstats
path: root/community/ruby-pygments
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-04-13 18:33:57 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-04-13 18:34:42 +0200
commit9e39e7951c2790d494a6cd571332cd8d39a8ad3b (patch)
treeec88cb256b66818400b4a1500c53ff8afc3c5d7d /community/ruby-pygments
parent96d1bb3fe7352089d25dbe2b3df84667b5f6e3ea (diff)
community/ruby-pygments: upgrade to 1.1.2
Diffstat (limited to 'community/ruby-pygments')
-rw-r--r--community/ruby-pygments/APKBUILD10
-rw-r--r--community/ruby-pygments/fix-gemspec.patch12
2 files changed, 18 insertions, 4 deletions
diff --git a/community/ruby-pygments/APKBUILD b/community/ruby-pygments/APKBUILD
index aa328e775cc..3eacebc55b0 100644
--- a/community/ruby-pygments/APKBUILD
+++ b/community/ruby-pygments/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=ruby-pygments
_gemname=pygments.rb
-pkgver=1.1.1
+pkgver=1.1.2
pkgrel=0
pkgdesc="Pygments syntax highlighting in Ruby"
url="https://github.com/tmm1/pygments.rb"
@@ -11,7 +11,8 @@ license="MIT"
depends="python2 py2-pygments ruby ruby-json ruby-multi_json"
checkdepends="ruby-bundler ruby-rake ruby-test-unit"
source="$pkgname-$pkgver.tar.gz::https://github.com/tmm1/$_gemname/archive/v$pkgver.tar.gz
- use-system-pygments-only.patch"
+ use-system-pygments-only.patch
+ fix-gemspec.patch"
builddir="$srcdir/$_gemname-$pkgver"
prepare() {
@@ -48,5 +49,6 @@ package() {
$_gemname-$pkgver.gem
}
-sha512sums="a3b687c0de3206e0d7220bbe3345f7e2abeb7bc03625f044f6bf0e75d45a8e6743ab91e14b950faa5ad80ca1514c764a6b919e592bd626d7002e435cc489ca5b ruby-pygments-1.1.1.tar.gz
-a8e5d64d8209dacb5090378e8507095359b38ef55ac6896f5bd95fa9676691beb278d6d19eb47cbc51fac843b326b8e21fbf1dd9ed39e123ed0943293b0a82ca use-system-pygments-only.patch"
+sha512sums="e7d6c7b391894d22edb6aa64d5aa604a6b43912245507b8693084dff8e02a33cd94cac0aa6dcd52040648019f8eadb88707b71aeffe5f0ce10002733a8dd674a ruby-pygments-1.1.2.tar.gz
+a8e5d64d8209dacb5090378e8507095359b38ef55ac6896f5bd95fa9676691beb278d6d19eb47cbc51fac843b326b8e21fbf1dd9ed39e123ed0943293b0a82ca use-system-pygments-only.patch
+ddc8654d788a9b3906fd8b92476bf3fe83b07d0206e32b21453e39cfa69e116ea9906a263d4427faf8eeb6a8595fce4af55281508f49103e87a8b31dd3dd99e1 fix-gemspec.patch"
diff --git a/community/ruby-pygments/fix-gemspec.patch b/community/ruby-pygments/fix-gemspec.patch
new file mode 100644
index 00000000000..05c509a626f
--- /dev/null
+++ b/community/ruby-pygments/fix-gemspec.patch
@@ -0,0 +1,12 @@
+Busybox find does not support -printf. Moreover, there are no symlinks
+in the tarball, so this exclude is quite useless.
+
+--- a/pygments.rb.gemspec
++++ b/pygments.rb.gemspec
+@@ -21,6 +21,5 @@
+ # s.extensions = ['ext/extconf.rb']
+ s.require_paths = ['lib']
+
+- exclude = `find . -type l -printf '%P\\0'`.split("\0").map {|f| "':!#{f}'" } * ' '
+ s.files = `git ls-files -- . #{exclude}`.split("\n")
+ end