aboutsummaryrefslogtreecommitdiffstats
path: root/community/ruby2.2
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-22 15:01:21 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-22 15:04:03 +0000
commit1a408c81eff69d6f4d8ef63d756fddac44f4a58e (patch)
treee5b6dc026536c73790348688a6f870276ad7d75f /community/ruby2.2
parent6cc513143e80a5762cf43a748175bba604453024 (diff)
community/ruby2.2: enable on aarch64
add no-omit-frame-pointer to CPPFLAGS
Diffstat (limited to 'community/ruby2.2')
-rw-r--r--community/ruby2.2/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/community/ruby2.2/APKBUILD b/community/ruby2.2/APKBUILD
index f13df700d18..7b66978cd89 100644
--- a/community/ruby2.2/APKBUILD
+++ b/community/ruby2.2/APKBUILD
@@ -9,7 +9,7 @@ _abiver="$_majorver.0"
pkgrel=0
pkgdesc="An object-oriented language for quick and easy programming"
url="http://www.ruby-lang.org/en/"
-arch="all !aarch64"
+arch="all"
license="Ruby"
depends=""
depends_dev="gmp-dev"
@@ -47,6 +47,7 @@ build() {
# In many places aliasing rules are broken; play it safe
# as it's risky with newer compilers to leave it as it is.
export CFLAGS="$CFLAGS -fno-omit-frame-pointer -fno-strict-aliasing"
+ export CPPFLAGS="$CPPFLAGS -fno-omit-frame-pointer -fno-strict-aliasing"
# ruby saves path to install. we want use $PATH
export INSTALL=install