aboutsummaryrefslogtreecommitdiffstats
path: root/community/rust
diff options
context:
space:
mode:
authorMarat Safin <jeizsm@gmail.com>2017-11-24 12:55:56 +0300
committerJakub Jirutka <jakub@jirutka.cz>2017-11-25 22:56:34 +0100
commit07bfc35e9ce6118bad6f42a2a2d0b8ab513aa0db (patch)
treed4220785ebdd4517bcea8b48f95a3c75078baa7a /community/rust
parent1ad9ac4dfce192b917e228e81514932c791b4490 (diff)
community/rust: upgrade to 1.22.1
Diffstat (limited to 'community/rust')
-rw-r--r--community/rust/APKBUILD14
-rw-r--r--community/rust/alpine-target.patch12
-rw-r--r--community/rust/musl-fix-static-linking.patch6
3 files changed, 18 insertions, 14 deletions
diff --git a/community/rust/APKBUILD b/community/rust/APKBUILD
index 5aef87888eb..2d7b1e0e49b 100644
--- a/community/rust/APKBUILD
+++ b/community/rust/APKBUILD
@@ -3,10 +3,10 @@
# Contributor: Jeizsm <jeizsm@gmail.com>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=rust
-pkgver=1.21.0
+pkgver=1.22.1
_llvmver=4
-_bootver=1.20.0
-pkgrel=1
+_bootver=1.21.1
+pkgrel=0
pkgdesc="The Rust Programming Language (compiler)"
url="http://www.rust-lang.org"
arch="x86_64"
@@ -23,7 +23,7 @@ depends="$pkgname-stdlib=$pkgver-r$pkgrel gcc llvm-libunwind-dev musl-dev"
# * libffi-dev is needed just because we compile llvm with LLVM_ENABLE_FFI.
makedepends="rust>=$_bootver cargo
cmake file libffi-dev llvm$_llvmver-dev llvm$_llvmver-test-utils
- python2 tar zlib-dev"
+ python2 tar zlib-dev bash"
subpackages="$pkgname-dbg $pkgname-stdlib
$pkgname-gdb::noarch $pkgname-lldb::noarch $pkgname-doc"
@@ -166,8 +166,8 @@ _mv() {
mv $@
}
-sha512sums="47f29a5c9c926c1b209516a8546c67a24c1c6ee15c6302c8c6d340047b3e1f713cc6d09e568b67ae4b47b08cbb0befd95fc0d7a72f2ce21a5224d4e5da03b4f5 rustc-1.21.0-src.tar.gz
-e4675fb78920a31c2c6b0ffdf812b127d3c585557eba904d3aeb690362b06697cbd3cf307bb4bebaec2bfaa1057c5e3738b33437f53db0eae9836ae18d36a880 musl-fix-static-linking.patch
+sha512sums="cb1f0f5643c5244225255030bef974eb8d642c9a9f04d3a1ba44157b3848ca2ee0c1b96160c19e6e0e110d0065836f99936f00678690840aa8f34e22ecece874 rustc-1.22.1-src.tar.gz
+cee98ff6cded8a330e383b8b88423b10b7c2cdcb711b31f4685abae7a60f85869e87f3096eb2d90a83dafeeba98b6f153b5e67d88f5cacc368dc53c701fe495b musl-fix-static-linking.patch
360b0c1b6374cb356989b6f254da2dfc2ab2390c8251f0151492206b908ebf85c6ff57405394b3f46f1fc3e26f7c986bb9e924065f4c4dfa1d50fff2a99b5cd0 musl-fix-linux_musl_base.patch
dc6432293bd060d5e3a73f25870867654fae61995dcd919e244a2dc686b6107556deed8c59ca6002182bfeff5ebc1ca2b89c4028ab0fbfb79e65defe47c9b4b0 llvm-with-ffi.patch
936ddccb357307b3f7f3c10aadcdc3dfbbe0ccb8cc5675969a87b7cf1a8e72f73ed5118c6cd6a1a36a377457ead998cc8c71f4176361acb4416ec16673b4c597 static-pie.patch
@@ -175,5 +175,5 @@ b5c8a4faf3571b5c79b052103639ea3b14f094ec0999963602111608afa1159219f958decf0b45dd
d352614e7c774e181decae210140e789de7fc090327ff371981ad28a11ce51c8c01b27c1101a24bb84d75ed2f706f67868f7dbc52196d4ccdf4ebd2d6d6b6b5e minimize-rpath.patch
498f4649163974afc4f042c43cd0c15d36784031514201a2962061f288a9336c2bc9749f8d2308b8ce3656f8097b5fc5bef505f61e2a6ed422ef4153f5339d77 alpine-move-py-scripts-to-share.patch
0542e8ffeb7ff6017aeec84d99c14802c6536433b41dafe7c8fc0c40908548228f34ef142ad6ad94235115b05f02ce157553b470b0f242292f90f3125b249e94 alpine-change-rpath-to-rustlib.patch
-b9d07a5dcc2485da72d02667891f7ccb015b1a4e648273d15532756ed98e7eeeff35f3af53d1aae1d953dc4364e42491fadb78e8bac1643851e25b81b490356d alpine-target.patch
+d769370adf0cb387d71aa85332fb77b9ebda0bca78599462a570dd23df0a9b6bcc18d815f4b0c012a3b90ad7f648b5d96f54a4dd88191db401cd681c391fa8a5 alpine-target.patch
79549055dea81379c890b495c82456ab497a9179ec6702c59e11d0748bc668f47fc3d6a69c27a0545bb87c01318631dffc69260bf2d4badc75f53cbf7fad7528 check-rustc"
diff --git a/community/rust/alpine-target.patch b/community/rust/alpine-target.patch
index 0bd52655e12..d8cd7d7b1c6 100644
--- a/community/rust/alpine-target.patch
+++ b/community/rust/alpine-target.patch
@@ -25,7 +25,7 @@ and distribution-specific quirks instead of polluting the main musl target of
/// Everything `rustc` knows about how to compile for a specific target.
--- /dev/null
+++ b/src/librustc_back/target/i586_alpine_linux_musl.rs
-@@ -0,0 +1,34 @@
+@@ -0,0 +1,35 @@
+// Copyright 2017 The Rust Project Developers. See the COPYRIGHT
+// file at the top-level directory of this distribution and at
+// http://rust-lang.org/COPYRIGHT.
@@ -51,6 +51,7 @@ and distribution-specific quirks instead of polluting the main musl target of
+ llvm_target: "i586-alpine-linux-musl".to_string(),
+ target_endian: "little".to_string(),
+ target_pointer_width: "32".to_string(),
++ target_c_int_width: "32".to_string(),
+ data_layout: "e-m:e-p:32:32-f64:32:64-f80:32-n8:16:32-S128".to_string(),
+ arch: "x86".to_string(),
+ target_os: "linux".to_string(),
@@ -62,7 +63,7 @@ and distribution-specific quirks instead of polluting the main musl target of
+}
--- /dev/null
+++ b/src/librustc_back/target/x86_64_alpine_linux_musl.rs
-@@ -0,0 +1,34 @@
+@@ -0,0 +1,35 @@
+// Copyright 2017 The Rust Project Developers. See the COPYRIGHT
+// file at the top-level directory of this distribution and at
+// http://rust-lang.org/COPYRIGHT.
@@ -88,6 +89,7 @@ and distribution-specific quirks instead of polluting the main musl target of
+ llvm_target: "x86_64-alpine-linux-musl".to_string(),
+ target_endian: "little".to_string(),
+ target_pointer_width: "64".to_string(),
++ target_c_int_width: "32".to_string(),
+ data_layout: "e-m:e-i64:64-f80:128-n8:16:32:64-S128".to_string(),
+ arch: "x86_64".to_string(),
+ target_os: "linux".to_string(),
@@ -99,7 +101,7 @@ and distribution-specific quirks instead of polluting the main musl target of
+}
--- /dev/null
+++ b/src/librustc_back/target/aarch64_alpine_linux_musl.rs
-@@ -0,0 +1,38 @@
+@@ -0,0 +1,39 @@
+// Copyright 2017 The Rust Project Developers. See the COPYRIGHT
+// file at the top-level directory of this distribution and at
+// http://rust-lang.org/COPYRIGHT.
@@ -126,6 +128,7 @@ and distribution-specific quirks instead of polluting the main musl target of
+ llvm_target: "aarch64-alpine-linux-musl".to_string(),
+ target_endian: "little".to_string(),
+ target_pointer_width: "64".to_string(),
++ target_c_int_width: "32".to_string(),
+ data_layout: "e-m:e-i8:8:32-i16:16:32-i64:64-i128:128-n32:64-S128".to_string(),
+ arch: "aarch64".to_string(),
+ target_os: "linux".to_string(),
@@ -140,7 +143,7 @@ and distribution-specific quirks instead of polluting the main musl target of
+}
--- /dev/null
+++ b/src/librustc_back/target/arm_alpine_linux_musleabihf.rs
-@@ -0,0 +1,40 @@
+@@ -0,0 +1,41 @@
+// Copyright 2017 The Rust Project Developers. See the COPYRIGHT
+// file at the top-level directory of this distribution and at
+// http://rust-lang.org/COPYRIGHT.
@@ -169,6 +172,7 @@ and distribution-specific quirks instead of polluting the main musl target of
+ llvm_target: "arm-alpine-linux-musleabihf".to_string(),
+ target_endian: "little".to_string(),
+ target_pointer_width: "32".to_string(),
++ target_c_int_width: "32".to_string(),
+ data_layout: "e-m:e-p:32:32-i64:64-v128:64:128-a:0:32-n32-S64".to_string(),
+ arch: "arm".to_string(),
+ target_os: "linux".to_string(),
diff --git a/community/rust/musl-fix-static-linking.patch b/community/rust/musl-fix-static-linking.patch
index 1e228a03071..fe9b39ea64f 100644
--- a/community/rust/musl-fix-static-linking.patch
+++ b/community/rust/musl-fix-static-linking.patch
@@ -29,9 +29,9 @@ static linking is requested, instead of dynamically as before.
- // on other dylibs (e.g. other native deps).
+ // libraries as that would violate the structure of the DAG.
+ cmd.start_group();
- add_local_native_libraries(cmd, sess);
- add_upstream_rust_crates(cmd, sess, crate_type, tmpdir);
- add_upstream_native_libraries(cmd, sess, crate_type);
+ add_local_native_libraries(cmd, sess, trans);
+ add_upstream_rust_crates(cmd, sess, trans, crate_type, tmpdir);
+ add_upstream_native_libraries(cmd, sess, trans, crate_type);
+ cmd.end_group();
// # Telling the linker what we're doing