aboutsummaryrefslogtreecommitdiffstats
path: root/community/seahorse/APKBUILD
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-10-03 12:30:57 +0200
committerRasmus Thomsen <oss@cogitri.dev>2019-10-03 21:08:43 +0200
commit14e2556b549126be706c92712825d6b6532cae0b (patch)
tree10943e532fcb642c705dce6fc4f334a28ad2babb /community/seahorse/APKBUILD
parent86073322e582bd0d481a514641017f6d1363c82f (diff)
community/seahorse: upgrade to 3.34
* Style fixes
Diffstat (limited to 'community/seahorse/APKBUILD')
-rw-r--r--community/seahorse/APKBUILD18
1 files changed, 7 insertions, 11 deletions
diff --git a/community/seahorse/APKBUILD b/community/seahorse/APKBUILD
index aa1c2e6c3e4..141cc21530b 100644
--- a/community/seahorse/APKBUILD
+++ b/community/seahorse/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=seahorse
-pkgver=3.32.2
+pkgver=3.34
pkgrel=0
pkgdesc="GNOME application for managing PGP keys."
url="https://projects.gnome.org/seahorse/"
@@ -9,28 +9,24 @@ arch="all"
license="GPL-2.0-or-later"
depends="openssh dconf"
makedepends="vala libxml2-utils
-yelp-tools intltool itstool gpgme-dev libsoup-dev
-libsm-dev libsecret-dev gobject-introspection
-gtk+3.0-dev gcr-dev glib-dev meson ninja
-cmake libpwquality-dev openldap-dev avahi-dev"
+ yelp-tools intltool itstool gpgme-dev libsoup-dev
+ libsm-dev libsecret-dev gobject-introspection
+ gtk+3.0-dev gcr-dev glib-dev meson ninja
+ cmake libpwquality-dev openldap-dev avahi-dev"
subpackages="$pkgname-lang $pkgname-doc"
-source="https://download.gnome.org/sources/$pkgname/${pkgver:0:4}/$pkgname-$pkgver.tar.xz"
-builddir="$srcdir"/$pkgname-$pkgver
+source="https://download.gnome.org/sources/seahorse/$pkgver/seahorse-$pkgver.tar.xz"
build() {
- cd "$builddir"
meson --prefix=/usr builddir
ninja -C builddir
}
check() {
- cd "$builddir"
meson test -C builddir
}
package() {
- cd "$builddir"
DESTDIR="$pkgdir" meson install -C builddir
}
-sha512sums="e372f79907fbc5d60a41ea0db3a91575b0b304c1727c6091f94eec28445cd836faa32754582c59fd1eb8ce784986e63b4c8cabbd46d5e4cacec1150d9ca08481 seahorse-3.32.2.tar.xz"
+sha512sums="06cbb8982bccabf1cfdcbb9ec7178681ec1b7f210d7401a145506defe90f38a6ef14a643c3c248164aff1e6f6943caa35db05263fc66c42fc1292e925110faf9 seahorse-3.34.tar.xz"