aboutsummaryrefslogtreecommitdiffstats
path: root/community/shotwell/APKBUILD
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-09-01 00:15:34 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-09-07 11:37:48 +0200
commit65504eb1b94a2a03d5cbe0471fd7dd25af4a72c0 (patch)
tree8e2b1b221b1e535b4419fab045063828931374f4 /community/shotwell/APKBUILD
parent39452aa5011a439e522cc56530960a6ccf1984f3 (diff)
community/shotwell: use abuild-meson & meson compile/test/install
Diffstat (limited to 'community/shotwell/APKBUILD')
-rw-r--r--community/shotwell/APKBUILD13
1 files changed, 4 insertions, 9 deletions
diff --git a/community/shotwell/APKBUILD b/community/shotwell/APKBUILD
index 9f78dffc2b4..142b221823c 100644
--- a/community/shotwell/APKBUILD
+++ b/community/shotwell/APKBUILD
@@ -16,23 +16,18 @@ checkdepends="desktop-file-utils appstream-glib"
source="https://download.gnome.org/sources/shotwell/${pkgver%.*}/shotwell-$pkgver.tar.xz"
build() {
- meson \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --localstatedir=/var \
- --buildtype=plain \
+ abuild-meson \
-Dinstall-apport-hook=false \
. output
- ninja -C output
+ meson compile ${JOBS:+-j ${JOBS}} -C output
}
check() {
- ninja -C output test
+ meson test --no-rebuild -v -C output
}
package() {
- DESTDIR="$pkgdir" ninja -C output install
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
sha512sums="4c84b5702476f264bd475fa93eff2e58f2876b076f186fc19b3dbddaae76b80485793b887f668788ac3c7f7230eb0c6a61fef2c0c70d52c665d0e49f6deb0b11 shotwell-0.30.10.tar.xz"