aboutsummaryrefslogtreecommitdiffstats
path: root/community/shotwell/APKBUILD
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-09-15 16:10:04 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-09-15 16:28:46 +0000
commitf2c6b85958c712efb7c549a865770b5627cf67dc (patch)
tree48121755530ef3f393828863644100b76fe84516 /community/shotwell/APKBUILD
parentbc57bce77ee9cb6a86965e848d88d380a0d7152f (diff)
community/shotwell: upgrade to 0.27.0, modernize APKBUILD, added check()
Diffstat (limited to 'community/shotwell/APKBUILD')
-rw-r--r--community/shotwell/APKBUILD25
1 files changed, 13 insertions, 12 deletions
diff --git a/community/shotwell/APKBUILD b/community/shotwell/APKBUILD
index 7cdb67b7f79..cf1cc9624d6 100644
--- a/community/shotwell/APKBUILD
+++ b/community/shotwell/APKBUILD
@@ -1,39 +1,40 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=shotwell
-pkgver=0.26.2
-pkgrel=1
+pkgver=0.27.0
+pkgrel=0
pkgdesc="A digital photo organizer designed for the GNOME desktop environment"
url="https://wiki.gnome.org/Apps/Shotwell"
arch="x86 x86_64"
license="LGPL2.1"
install="shotwell.post-upgrade shotwell.post-install shotwell.pre-deinstall"
-depends=""
subpackages="$pkgname-lang $pkgname-doc"
makedepends="intltool vala libgee-dev libunique3-dev webkit2gtk-dev libexif-dev
librsvg-dev sqlite-dev libgudev-dev dbus-glib-dev libgphoto2-dev
gexiv2-dev libraw-dev librsvg-dev json-glib-dev gnome-doc-utils
m4 gst-plugins-base-dev bash gtk+3.0-dev rest-dev desktop-file-utils
gcr-dev itstool libgdata-dev"
-source="https://download.gnome.org/sources/shotwell/${pkgver%.*}/shotwell-$pkgver.tar.xz
- "
-
+source="https://download.gnome.org/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
builddir="$srcdir"/$pkgname-$pkgver
build() {
cd "$builddir"
./configure \
--build=$CBUILD \
+ --host=$CHOST \
--prefix=/usr \
- --disable-desktop-update \
- --disable-icon-update \
- --disable-schemas-compile \
- || return 1
+ --enable-static=no \
+ --disable-schemas-compile
make
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
-sha512sums="a38681cb1b192372381d67abdc6c088c80fcc1db0d8d328330ee8f1ab78608c742de5e33030ccb1b941f1583a2b7028caadf61ce10ba7f2a93863bd2c3019813 shotwell-0.26.2.tar.xz"
+sha512sums="e7b5fe153fff96e04507588b4b8a1e71c121787cb6d28b7e14bb31824f1a09ca1948edc4bccfa069b2ffebe1ac753580257c1af4b7aec0ed49af74944ee91fbb shotwell-0.27.0.tar.xz"