aboutsummaryrefslogtreecommitdiffstats
path: root/community/speedometer
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-07-21 18:29:02 +0000
committerJakub Jirutka <jakub@jirutka.cz>2017-07-21 23:38:26 +0200
commit21e5cf4d96df4b6256d19cb3e5568555723d482b (patch)
tree63e5e24778a9176764a16682d00b18ab9e3ad72d /community/speedometer
parentcc8e9750b2911b617671598e60ec9125585ae4cb (diff)
community/speedometer: modernize APKBUILD
Diffstat (limited to 'community/speedometer')
-rw-r--r--community/speedometer/APKBUILD19
1 files changed, 3 insertions, 16 deletions
diff --git a/community/speedometer/APKBUILD b/community/speedometer/APKBUILD
index 7a6abc5e1bc..902681747e0 100644
--- a/community/speedometer/APKBUILD
+++ b/community/speedometer/APKBUILD
@@ -7,25 +7,12 @@ pkgdesc="Measure and display the rate of data across a network connection or dat
url="http://excess.org/speedometer/"
arch="noarch"
license="LGPL"
-depends="python2 py-urwid"
-makedepends=
-install=
-subpackages=
+depends="python2 py2-urwid"
source="http://excess.org/$pkgname/$pkgname-$pkgver.tar.gz"
-
-_builddir="$srcdir"/$pkgname-$pkgver
-
-prepare() {
- cd "$_builddir"
- # apply patches here
-}
-
-build() {
- return 0
-}
+builddir="$srcdir/$pkgname-$pkgver"
package() {
- cd "$_builddir"
+ cd "$builddir"
install -Dm755 speedometer.py "$pkgdir"/usr/bin/speedometer
}