aboutsummaryrefslogtreecommitdiffstats
path: root/community/sway
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2019-03-13 13:57:52 -0600
committerHenrik Riomar <henrik.riomar@gmail.com>2019-03-13 21:01:53 +0100
commitbf0d8e597720e48903734fc1d292bb61325b1726 (patch)
tree26f90bb7b060b3de76a623be73c607da10546b4e /community/sway
parentfd93759e98e3ccc9b5a2c96a02f24010f6c60d5e (diff)
community/sway: move from testing
Diffstat (limited to 'community/sway')
-rw-r--r--community/sway/APKBUILD84
1 files changed, 84 insertions, 0 deletions
diff --git a/community/sway/APKBUILD b/community/sway/APKBUILD
new file mode 100644
index 00000000000..d107ea5ff54
--- /dev/null
+++ b/community/sway/APKBUILD
@@ -0,0 +1,84 @@
+# Contributor: Henrik Riomar <henrik.riomar@gmail.com>
+# Maintainer: Drew DeVault <sir@cmpwn.com>
+pkgname=sway
+pkgver=1.0
+_pkgver=1.0
+pkgrel=0
+pkgdesc="i3 compatible window manager for Wayland"
+url="http://swaywm.org"
+arch="all"
+license="MIT"
+options="suid !check"
+depends=""
+makedepends="cairo-dev
+ cmake
+ gdk-pixbuf-dev
+ json-c-dev
+ libevdev-dev
+ libinput-dev
+ libxkbcommon-dev
+ linux-pam-dev
+ meson
+ ninja
+ pango-dev
+ pcre2-dev
+ scdoc
+ wayland-dev
+ wayland-protocols
+ wlroots-dev
+ "
+subpackages="
+ $pkgname-doc
+ $pkgname-bash-completion:bashcomp:noarch
+ $pkgname-fish-completion:fishcomp:noarch
+ $pkgname-zsh-completion:zshcomp:noarch
+ "
+source="$pkgname-$_pkgver.tar.gz::https://github.com/swaywm/$pkgname/archive/$_pkgver.tar.gz
+ "
+builddir="$srcdir/$pkgname-$_pkgver"
+
+build() {
+ cd "$builddir"
+ meson \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --buildtype=release \
+ . output
+ ninja -C output
+}
+
+bashcomp() {
+ depends=""
+ pkgdesc="Bash completions for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
+
+ mkdir -p "$subpkgdir"/usr/share/
+ mv "$pkgdir"/usr/share/bash-completion "$subpkgdir"/usr/share/
+}
+
+fishcomp() {
+ depends=""
+ pkgdesc="Fish completions for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel fish"
+
+ mkdir -p "$subpkgdir"/usr/share/fish
+ mv "$pkgdir"/usr/share/fish/completions "$subpkgdir"/usr/share/fish
+}
+
+zshcomp() {
+ depends=""
+ pkgdesc="Zsh completions for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel zsh"
+
+ mkdir -p "$subpkgdir"/usr/share/zsh
+ mv "$pkgdir"/usr/share/zsh/site-functions "$subpkgdir"/usr/share/zsh
+}
+
+package() {
+ cd "$builddir"
+ DESTDIR="$pkgdir" ninja -C output install
+ chmod u+s "$pkgdir"/usr/bin/sway
+}
+
+sha512sums="57e2610244c8bcd2b09bb5396113176d118ee5a0688aea297d4c191eda70ce29b36ff64e05c57d1a32a31cc4f2ac2562fd3cb3890508a8f3c7cbcb9fb017171d sway-1.0.tar.gz"