aboutsummaryrefslogtreecommitdiffstats
path: root/community/sxhkd/APKBUILD
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2018-03-28 12:38:24 +0000
committerSören Tempel <soeren+git@soeren-tempel.net>2018-03-28 15:37:18 +0200
commit3233790279c8a58e6a4afcb5fef361af01fc3dbf (patch)
treea8a7063eb70509770279bbc8852f18e0797a42c9 /community/sxhkd/APKBUILD
parent98af2a38e50e6d7e1cc10e448e5472a7a194dad3 (diff)
testing/sxhkd: adopt package, move to community
Diffstat (limited to 'community/sxhkd/APKBUILD')
-rw-r--r--community/sxhkd/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/community/sxhkd/APKBUILD b/community/sxhkd/APKBUILD
new file mode 100644
index 00000000000..a937ef46ea2
--- /dev/null
+++ b/community/sxhkd/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Olivier Mauras <olivier@mauras.ch>
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer: prspkt <prspkt@protonmail.com>
+pkgname=sxhkd
+pkgver=0.5.9
+pkgrel=1
+pkgdesc="Simple X hotkey daemon"
+url="https://github.com/baskerville/sxhkd"
+arch="all"
+license="BSD-2-Clause"
+makedepends="libxcb-dev xcb-util-keysyms-dev"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/baskerville/sxhkd/archive/$pkgver.tar.gz"
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ make PREFIX=/usr
+}
+
+package() {
+ cd "$builddir"
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+}
+
+sha512sums="32ee7261b4fa10d5a62a7fa61e689977d12afd654e81123711bda1f006e4b6baa7524352086037594e6ef1989dd8fcb6eddc1114085ee91546a69f6d1146924e sxhkd-0.5.9.tar.gz"