aboutsummaryrefslogtreecommitdiffstats
path: root/community/sxmo-dmenu/APKBUILD
diff options
context:
space:
mode:
authorAnjandev Momi <anjan@momi.ca>2021-06-03 02:27:03 +0000
committerAriadne Conill <ariadne@dereferenced.org>2021-06-03 04:00:20 +0000
commitc5dd29dc85dfc223acac82309268911934470263 (patch)
tree47eb8d116b6bee5b9b7b6c22dd4c3dd8643af95d /community/sxmo-dmenu/APKBUILD
parent25db1f934a960df52b065cac0b649500289a8a77 (diff)
community/sxmo-dmenu: move from testing
Diffstat (limited to 'community/sxmo-dmenu/APKBUILD')
-rw-r--r--community/sxmo-dmenu/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/sxmo-dmenu/APKBUILD b/community/sxmo-dmenu/APKBUILD
new file mode 100644
index 00000000000..472eeaace8c
--- /dev/null
+++ b/community/sxmo-dmenu/APKBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Anjandev Momi <anjan@momi.ca>
+pkgname=sxmo-dmenu
+pkgver=5.0.9
+pkgrel=0
+pkgdesc="Dmenu fork for Sxmo UI; supports highlight, centering, volume-key navigation and more"
+url="https://git.sr.ht/~mil/sxmo-dmenu"
+arch="all"
+license="MIT"
+makedepends="libx11-dev libxinerama-dev libxft-dev"
+options="!check" # has no tests
+subpackages="$pkgname-doc"
+provides="dmenu"
+source="$pkgname-$pkgver.tar.gz::https://git.sr.ht/~mil/sxmo-dmenu/archive/$pkgver.tar.gz"
+
+prepare() {
+ default_prepare
+ sed -i -e '/CFLAGS/{s/-Os//;s/=/+=/}' \
+ -e '/LDFLAGS/{s/=/+=/}' \
+ "$builddir"/config.mk
+}
+
+build() {
+ make X11INC=/usr/include/X11 \
+ X11LIB=/usr/lib/X11 \
+ FREETYPEINC=/usr/include/freetype2 \
+ -C "$builddir"
+}
+
+package() {
+ make DESTDIR=$pkgdir PREFIX=/usr \
+ -C "$builddir" install
+}
+
+sha512sums="f49823ddf906c5096d8c932a2a529c3128df5d475575796778bf6cd43de4b8566b2c3cb0cfb8c4584cd9b575454f5d8adf8671bda1c73d912bacf51a57cb7814 sxmo-dmenu-5.0.9.tar.gz"