aboutsummaryrefslogtreecommitdiffstats
path: root/community/sylpheed/APKBUILD
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-05-29 11:21:16 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2019-06-05 19:38:55 +0000
commitd978b6187bf01b79629369998d45f46f4a3ae43d (patch)
tree2dc66630e7856af015f0d2054124ba536315fd53 /community/sylpheed/APKBUILD
parentaecaf7bb5af16cd331e9ce64bb369a409991781e (diff)
community/sylpheed: move from main
Diffstat (limited to 'community/sylpheed/APKBUILD')
-rw-r--r--community/sylpheed/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/community/sylpheed/APKBUILD b/community/sylpheed/APKBUILD
new file mode 100644
index 00000000000..098010eaa57
--- /dev/null
+++ b/community/sylpheed/APKBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=sylpheed
+pkgver=3.7.0
+pkgrel=2
+pkgdesc="Lightweight and user-friendly e-mail client"
+url="http://sylpheed.sraoss.jp/en/"
+arch="all"
+license="GPL-3.0-only"
+depends="pinentry-gtk"
+makedepends="gtk+-dev openldap-dev openssl-dev gpgme-dev"
+subpackages="$pkgname-dev $pkgname-lang"
+source="https://osdn.net/dl/sylpheed/$pkgname-$pkgver.tar.xz"
+
+build() {
+ cd "$srcdir/sylpheed-$pkgver"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --enable-ldap \
+ --disable-gtkspell \
+ --enable-gpgme
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="1f3255dd61878e9f52f78cd68a76712835c376296ddfa72034a0415f17843eaa334fb6019900b2fa18ccc600d918945febd7ffdfde91990a4e9f5c05a1609c76 sylpheed-3.7.0.tar.xz"