aboutsummaryrefslogtreecommitdiffstats
path: root/community/tclap
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-03-07 01:01:51 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-03-07 01:01:51 +0100
commit3830c6fe4bfecb2fbe07bf051b1274c9d2f8ccb8 (patch)
tree9af60009618732a46146ca8d5fa78c03fd254ca9 /community/tclap
parent9cf30b507b4ea1e0db6ba9e8fd437846ea5f2178 (diff)
community/tclap: move from testing
Diffstat (limited to 'community/tclap')
-rw-r--r--community/tclap/APKBUILD35
-rw-r--r--community/tclap/skip-docs.patch23
2 files changed, 58 insertions, 0 deletions
diff --git a/community/tclap/APKBUILD b/community/tclap/APKBUILD
new file mode 100644
index 00000000000..c86a6e3e537
--- /dev/null
+++ b/community/tclap/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=tclap
+pkgver=1.2.1
+pkgrel=0
+pkgdesc="Templatized C++ Command Line Parser"
+url="http://tclap.sourceforge.net"
+arch="noarch"
+license="MIT"
+subpackages="$pkgname-dev"
+source="https://sourceforge.net/projects/tclap/files/$pkgname-$pkgver.tar.gz
+ skip-docs.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ && make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="8bd6ee724600880840048c7b36f02d31b1aa4910b17f80fb04aef89b1f1917856d9979ec488edbd457b66d9d689aea97540abb842a8b902bbd75c66a6e07b9b1 tclap-1.2.1.tar.gz
+d88b298d5de2c1e8b628babc75b0a075b1c359c76b67d068e233e248c3b08dc7374865c1e725e4945fa900647d7bbf80cdaf7cbef2f198813ffa69844d04ee0b skip-docs.patch"
diff --git a/community/tclap/skip-docs.patch b/community/tclap/skip-docs.patch
new file mode 100644
index 00000000000..0f5b5b4224b
--- /dev/null
+++ b/community/tclap/skip-docs.patch
@@ -0,0 +1,23 @@
+Make fails to install docs, so just skip them.
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,7 +1,7 @@
+
+ ACLOCAL_AMFLAGS = -I config
+
+-SUBDIRS = include examples docs tests msc config
++SUBDIRS = include examples tests msc config
+
+ pkgconfigdir = $(libdir)/pkgconfig
+ pkgconfig_DATA = $(PACKAGE).pc
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -173,7 +173,7 @@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+ ACLOCAL_AMFLAGS = -I config
+-SUBDIRS = include examples docs tests msc config
++SUBDIRS = include examples tests msc config
+ pkgconfigdir = $(libdir)/pkgconfig
+ pkgconfig_DATA = $(PACKAGE).pc
+ EXTRA_DIST = $(PACKAGE).pc.in