aboutsummaryrefslogtreecommitdiffstats
path: root/community/terminator/APKBUILD
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-06-30 07:48:01 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-06-30 07:48:07 +0000
commit4cb1f8767e36e1539778daba4c4a905257801089 (patch)
treefda866dcb948c13ca8510566c470d3662551516f /community/terminator/APKBUILD
parent5b6f6cc7911839997ff56435fdddea98bc083b22 (diff)
community/terminator: added missing dependencies, added check()
Diffstat (limited to 'community/terminator/APKBUILD')
-rw-r--r--community/terminator/APKBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/community/terminator/APKBUILD b/community/terminator/APKBUILD
index 9e4a1ebc3bd..a469d5ce797 100644
--- a/community/terminator/APKBUILD
+++ b/community/terminator/APKBUILD
@@ -2,20 +2,24 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=terminator
pkgver=1.91
-pkgrel=2
+pkgrel=3
pkgdesc="Terminal emulator that supports tabs and grids"
url="http://gnometerminator.blogspot.fr/p/introduction.html"
arch="noarch"
license="GPL2"
-depends="py-gtk xdg-utils vte dbus-glib gettext intltool keybinder3
- gconf gsettings-desktop-schemas"
-makedepends=""
-install=""
+depends="python2 py-gtk xdg-utils vte3 dbus-glib gettext intltool keybinder3
+ gconf gsettings-desktop-schemas py2-gobject3 py2-cairo py-dbus py-psutil"
+makedepends="python2-dev"
subpackages="$pkgname-doc $pkgname-lang"
source="https://launchpad.net/$pkgname/gtk3/$pkgver/+download/$pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$pkgname-$pkgver
+check() {
+ cd "$builddir"
+ python2 setup.py check
+}
+
build() {
cd "$builddir"
python2 setup.py build