aboutsummaryrefslogtreecommitdiffstats
path: root/community/tg
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-12-31 19:16:53 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-12-31 20:27:13 +0100
commit60dbf73e0fc7ab28d23159013a44be36db8fce3d (patch)
treea54ed457d97abcac3a6512208724d10a004c7224 /community/tg
parente550ebe21bac10ef10d1466e148d779aae5ba727 (diff)
community/tg: build with lua5.3 instead of lua5.2
Diffstat (limited to 'community/tg')
-rw-r--r--community/tg/APKBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/community/tg/APKBUILD b/community/tg/APKBUILD
index c61b4e952e9..70c272e6126 100644
--- a/community/tg/APKBUILD
+++ b/community/tg/APKBUILD
@@ -2,14 +2,14 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=tg
pkgver=1.3.1
-pkgrel=7
+pkgrel=8
_tglver=2.0.1
_tlparserver=0_git20151118
pkgdesc="Command line Telegram client"
url="https://github.com/vysheng/tg"
arch="all !s390x"
license="GPL-3.0"
-depends_dev="readline-dev libressl-dev libconfig-dev libevent-dev jansson-dev lua5.2-dev"
+depends_dev="readline-dev libressl-dev libconfig-dev libevent-dev jansson-dev lua5.3-dev"
makedepends="$depends_dev zlib-dev grep"
provides="telegram-cli"
source="$pkgname-$pkgver.tar.gz::https://github.com/vysheng/tg/archive/$pkgver.tar.gz
@@ -35,9 +35,9 @@ prepare() {
build() {
cd "$builddir"
- export LUA=/usr/bin/lua5.2
- export LUA_INCLUDE=-I/usr/include/lua5.2
- export LUA_LIB=$(pkg-config --libs lua5.2)
+ export LUA=/usr/bin/lua5.3
+ export LUA_INCLUDE=-I/usr/include/lua5.3
+ export LUA_LIB=$(pkg-config --libs lua5.3)
./configure \
--prefix=/usr \
--sysconfdir=/etc \