aboutsummaryrefslogtreecommitdiffstats
path: root/community/uhttpmock/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-04-12 15:46:33 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-04-12 15:46:33 +0000
commita7cd4b5602d8f2620e00b2c1bd9c26f31bd5d2a6 (patch)
tree9ed0084d708cc1fb9d62754f861bed5b99cc8309 /community/uhttpmock/APKBUILD
parenta7c26d993c673a57afd7591f838c6d0c35e313b4 (diff)
community/uhttpmock: move from testing
needed by libgdata
Diffstat (limited to 'community/uhttpmock/APKBUILD')
-rw-r--r--community/uhttpmock/APKBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/community/uhttpmock/APKBUILD b/community/uhttpmock/APKBUILD
new file mode 100644
index 00000000000..5cf165bd89b
--- /dev/null
+++ b/community/uhttpmock/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer:
+pkgname=uhttpmock
+pkgver=0.5.0
+pkgrel=0
+pkgdesc="HTTP web service mocking library"
+url="http://gitorious.org/uhttpmock/"
+arch="all"
+license="LGPLv2"
+depends=""
+depends_dev="libsoup-dev glib-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://tecnocode.co.uk/downloads/uhttpmock/$pkgname-$pkgver.tar.xz"
+
+_builddir="$srcdir"/uhttpmock-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --disable-static \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="ebc54cbbe9b6695282a179af223fe374 uhttpmock-0.5.0.tar.xz"
+sha256sums="26da182a2db2579c5ba4dad9096d52099e0766228c295cfbaed6de4046f7d16e uhttpmock-0.5.0.tar.xz"
+sha512sums="952b618f3a12d7190f3812bc0bd53dd655a83d27f29bb749e62b36a08492bf535b85db7f5ff66f15c72bf5574696149f00476041f225ca6039ad87b221f5a1c6 uhttpmock-0.5.0.tar.xz"