aboutsummaryrefslogtreecommitdiffstats
path: root/community/uhttpmock/only-listen-on-ipv4.patch
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-06-01 15:42:37 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-06-02 15:18:54 +0000
commit13129b99661d439847296d2609e361ccda81e0b4 (patch)
tree86a391cb88f374f050d802b5fa8bad310bcdb513 /community/uhttpmock/only-listen-on-ipv4.patch
parentcbe1c6c8a287ec0a7c4005f35604835414bbb7da (diff)
community/uhttpmock: add patch to only listen on IPv4
* fix url & license * enable tests * modernize APKBUILD Closes GH-7597
Diffstat (limited to 'community/uhttpmock/only-listen-on-ipv4.patch')
-rw-r--r--community/uhttpmock/only-listen-on-ipv4.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/community/uhttpmock/only-listen-on-ipv4.patch b/community/uhttpmock/only-listen-on-ipv4.patch
new file mode 100644
index 00000000000..64a43672fa1
--- /dev/null
+++ b/community/uhttpmock/only-listen-on-ipv4.patch
@@ -0,0 +1,16 @@
+Upstream: No
+Reason: Docker by default doesn't enable IPv6, so tests using this will fail on
+CI and infra.
+diff --git a/libuhttpmock/uhm-server.c b/libuhttpmock/uhm-server.c
+index 5f59a23..11b113d 100644
+--- a/libuhttpmock/uhm-server.c
++++ b/libuhttpmock/uhm-server.c
+@@ -1393,7 +1393,7 @@ uhm_server_run (UhmServer *self)
+ g_main_context_push_thread_default (priv->server_context);
+
+ priv->server_main_loop = g_main_loop_new (priv->server_context, FALSE);
+- soup_server_listen_local (priv->server, 0, SOUP_SERVER_LISTEN_HTTPS,
++ soup_server_listen_local (priv->server, 0, SOUP_SERVER_LISTEN_HTTPS | SOUP_SERVER_LISTEN_IPV4_ONLY,
+ &error);
+ g_assert_no_error (error); /* binding to localhost should never really fail */
+