aboutsummaryrefslogtreecommitdiffstats
path: root/community/uhttpmock
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-04-12 17:14:00 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-04-12 17:15:57 +0000
commitc2b64262ce32cb46b4ce49d1af711ce251c6ac24 (patch)
tree143b09b382021e7926b6682c3c0a043d6484a8e3 /community/uhttpmock
parentc4f0699cfc757603e844927d7f7b11c906674f71 (diff)
community/uhttpmock: modernize
Diffstat (limited to 'community/uhttpmock')
-rw-r--r--community/uhttpmock/APKBUILD15
1 files changed, 3 insertions, 12 deletions
diff --git a/community/uhttpmock/APKBUILD b/community/uhttpmock/APKBUILD
index e50ab10c607..2137ab73589 100644
--- a/community/uhttpmock/APKBUILD
+++ b/community/uhttpmock/APKBUILD
@@ -12,19 +12,10 @@ install=""
subpackages="$pkgname-dev $pkgname-doc"
source="http://tecnocode.co.uk/downloads/uhttpmock/$pkgname-$pkgver.tar.xz"
-_builddir="$srcdir"/uhttpmock-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/uhttpmock-$pkgver
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -39,7 +30,7 @@ build() {
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
}