aboutsummaryrefslogtreecommitdiffstats
path: root/community/uncrustify/APKBUILD
diff options
context:
space:
mode:
authorAndré Klitzing <aklitzing@gmail.com>2017-03-24 09:59:28 +0100
committerWilliam Pitcock <nenolod@dereferenced.org>2017-03-24 23:32:23 +0000
commitc23ced255d0a9db314024b05035bc90a93d1eeb8 (patch)
treef0c9c2e38f6c294f912ec21c28ed757d0a4d0a26 /community/uncrustify/APKBUILD
parent6c32794afdf8e00f67ea8a5582afb347649ebf93 (diff)
testing/uncrustify: move to community
Diffstat (limited to 'community/uncrustify/APKBUILD')
-rw-r--r--community/uncrustify/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/uncrustify/APKBUILD b/community/uncrustify/APKBUILD
new file mode 100644
index 00000000000..6fb73cfb351
--- /dev/null
+++ b/community/uncrustify/APKBUILD
@@ -0,0 +1,35 @@
+# Maintainer: André Klitzing <aklitzing@gmail.com>
+
+pkgname=uncrustify
+pkgver=0.64
+pkgrel=0
+pkgdesc="A source code beautifier"
+url="https://github.com/uncrustify/uncrustify"
+arch="all"
+license="GPL2"
+makedepends="cmake"
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir"
+
+build() {
+ cd "$builddir"
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+}
+
+package() {
+ cd "$builddir"
+ install -d -m755 "$pkgdir"/usr/share/$pkgname
+ install -m644 etc/*.cfg "$pkgdir"/usr/share/$pkgname
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+
+ cd build
+ make DESTDIR="$pkgdir" PREFIX=/usr install
+}
+
+md5sums="008904ca40d07c4b3d66c717d59cb65b uncrustify-0.64.tar.gz"
+sha256sums="0fca05fe8bac2cd80bf3ed77378c82ffe365f37a3f80b8e0ca2dbb3c6e25f3d7 uncrustify-0.64.tar.gz"
+sha512sums="27be7bceccab20d58ad8f7bb875f1270771f9c0994d6aac404743028ccb9002229d5f000d7cfb4264e66409581f7339b88e17e5ad9b8dd2e8817431268411a0f uncrustify-0.64.tar.gz"