aboutsummaryrefslogtreecommitdiffstats
path: root/community/upx
diff options
context:
space:
mode:
authorinfo@mobile-stream.com <info@mobile-stream.com>2018-11-20 22:10:57 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-11-26 09:07:00 +0000
commitc03380fc5771a00c2e5f60690d00cfe1350e66bf (patch)
tree02a05ef863796cb0168dd863cde43b49ead8ed3a /community/upx
parent4fa23fb9dbd78174297a0780acc78107308347c5 (diff)
community/upx: fix build with gcc8 (-Werror too strict)
Diffstat (limited to 'community/upx')
-rw-r--r--community/upx/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/community/upx/APKBUILD b/community/upx/APKBUILD
index c112e2e514b..8f52ddeb201 100644
--- a/community/upx/APKBUILD
+++ b/community/upx/APKBUILD
@@ -2,7 +2,7 @@
# TODO: unbundle lzma-sdk
pkgname=upx
pkgver=3.94
-pkgrel=0
+pkgrel=1
pkgdesc="The Ultimate Packer for eXecutables"
url="https://upx.github.io"
arch="all"
@@ -24,6 +24,7 @@ prepare() {
build() {
cd "$builddir"
+ CXXFLAGS_WERROR="-Werror -Wno-error=class-memaccess" \
make UPX_LZMADIR="$srcdir" all
}