aboutsummaryrefslogtreecommitdiffstats
path: root/community/utf8proc
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-08-17 14:12:05 +0200
committerJakub Jirutka <jakub@jirutka.cz>2016-08-17 14:12:05 +0200
commit7cb5f3c15be16f3634622d1d20ae1489008f45ad (patch)
tree3429a889cfcb984b1063de6437d9f1714a540fe7 /community/utf8proc
parentcaf57ec52c3418da12a47a712d33da019932058a (diff)
community/utf8proc: move from testing
Diffstat (limited to 'community/utf8proc')
-rw-r--r--community/utf8proc/APKBUILD40
-rw-r--r--community/utf8proc/utf8proc.pc11
2 files changed, 51 insertions, 0 deletions
diff --git a/community/utf8proc/APKBUILD b/community/utf8proc/APKBUILD
new file mode 100644
index 00000000000..2a03999f2a0
--- /dev/null
+++ b/community/utf8proc/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=utf8proc
+pkgver=1.3.1
+pkgrel=0
+pkgdesc="A clean C library for processing UTF-8 Unicode data"
+url="https://github.com/JuliaLang/utf8proc"
+arch="all"
+license="MIT custom"
+depends=""
+makedepends=""
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/JuliaLang/$pkgname/archive/v$pkgver.tar.gz
+ $pkgname.pc
+ "
+builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ cd "$builddir"
+ sed "s/@VERSION@/$pkgver/" "$srcdir"/$pkgname.pc > $pkgname.pc
+}
+
+build() {
+ cd "$builddir"
+ make
+}
+
+package() {
+ cd "$builddir"
+
+ make DESTDIR="$pkgdir" prefix=/usr install || return 1
+ install -D $pkgname.pc "$pkgdir"/usr/lib/pkgconfig/$pkgname.pc
+}
+
+md5sums="347cbe5feef3d6714566bad06f1b0135 utf8proc-1.3.1.tar.gz
+7833a8bae857f4342f6f617b90a443e3 utf8proc.pc"
+sha256sums="83b60fe21fd8a017b8ad469515873893c8e911a5bef336a427594d398b5688cc utf8proc-1.3.1.tar.gz
+a6def2c16f03c6764ba87ff34b2026f1b008a28fc602aef94c96dccf632bc8c8 utf8proc.pc"
+sha512sums="9a78e2509ec84ce38a3fc4699311145603fcdf4a60974f738376d0b04f67ba27e36eefb5f3b3387e05b001564d7bad6312524ef73c017b9eb9e077aae7bbefcd utf8proc-1.3.1.tar.gz
+95e6fe681b9bd35414c2e1b1948ab9eb37274cfbd9e7b970bc7685eb7e03155bd08781b48f3084a2c81440a54f12d4130ed19e06fe4fcc0f1e45d99f225636d7 utf8proc.pc"
diff --git a/community/utf8proc/utf8proc.pc b/community/utf8proc/utf8proc.pc
new file mode 100644
index 00000000000..5349c7a2c0a
--- /dev/null
+++ b/community/utf8proc/utf8proc.pc
@@ -0,0 +1,11 @@
+prefix=/usr
+exec_prefix=${prefix}
+includedir=${prefix}/include
+libdir=${exec_prefix}/lib
+
+Name: utf8proc
+Version: @VERSION@
+Description: A clean C library for processing UTF-8 Unicode data
+URL: https://github.com/JuliaLang/utf8proc
+Cflags: -I${includedir}
+Libs: -L${libdir} -lutf8proc