aboutsummaryrefslogtreecommitdiffstats
path: root/community/vdesk
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-07-07 18:09:06 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-07-10 08:53:51 +0000
commit935783b4b95bc425b46052c4530ae9e6a1793c0c (patch)
tree0db2f2d6e6d97c807f0f7ee4e702c8bf217b4ff9 /community/vdesk
parentb0868bb482b84d9e55877a1ccd55bbf8725c1aef (diff)
community/vdesk: modernize APKBUILD
Diffstat (limited to 'community/vdesk')
-rw-r--r--community/vdesk/APKBUILD23
1 files changed, 5 insertions, 18 deletions
diff --git a/community/vdesk/APKBUILD b/community/vdesk/APKBUILD
index 1352649626e..acdbde596b9 100644
--- a/community/vdesk/APKBUILD
+++ b/community/vdesk/APKBUILD
@@ -7,35 +7,22 @@ pkgdesc="vdesk is a virtual desktop manager."
url="http://offog.org/code/vdesk/"
arch="all"
license="MIT"
-depends=""
-depends_dev=""
makedepends="libx11-dev"
-install=""
-subpackages=""
source="http://offog.org/files/${pkgname}-${pkgver}.tar.gz"
-_builddir=${srcdir}/${pkgname}-${pkgver}
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
- }
+builddir=${srcdir}/${pkgname}-${pkgver}
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
- --prefix=/usr || return 1
- make || return 1
+ --prefix=/usr
+ make
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install
}