aboutsummaryrefslogtreecommitdiffstats
path: root/community/vectorscan/APKBUILD
diff options
context:
space:
mode:
authorDuncan Bellamy <dunk@denkimushi.com>2021-10-08 05:33:56 +0000
committerAndy Postnikov <apostnikov@gmail.com>2021-10-10 21:53:52 +0000
commitd5d92f826a9a02bad6d06ce5d37c79b96bdd1c19 (patch)
tree45aa8b43122698b986c1e9add07eac1652d67fc5 /community/vectorscan/APKBUILD
parent572adadc199ecce868d5d04369c267edf6bb1218 (diff)
community/vectorscan: build with lowest armv8 arch
to stop startup failure with rspamd on aarch64
Diffstat (limited to 'community/vectorscan/APKBUILD')
-rw-r--r--community/vectorscan/APKBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/community/vectorscan/APKBUILD b/community/vectorscan/APKBUILD
index 73049914f80..618613788fd 100644
--- a/community/vectorscan/APKBUILD
+++ b/community/vectorscan/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
pkgname=vectorscan
pkgver=5.4.2
-pkgrel=2
+pkgrel=3
pkgdesc="High-performance regular expression matching library"
url="https://www.hyperscan.io"
arch="x86 x86_64 aarch64" #requires SSSE3 or Neon
@@ -17,6 +17,8 @@ build() {
case "${CARCH:-native}" in
x86|x86_64)
_march="-march=core2" ;;
+ aarch64)
+ _march="-march=armv8-a" ;;
esac
if [ "$CBUILD" != "$CHOST" ]; then