aboutsummaryrefslogtreecommitdiffstats
path: root/community/webkit2gtk/APKBUILD
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.eu>2018-07-13 17:29:29 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2018-07-13 16:53:15 +0000
commite6cdfd728202da0c5ab2be4e3db99b5010f85cce (patch)
treeecfc33ab156c2b07a99607942fe0b7316f3004b6 /community/webkit2gtk/APKBUILD
parentc38ad72bb9ffe18d13102961387b36e3c8f47edc (diff)
community/webkit2gtk: modernize, bump pkgrel
Diffstat (limited to 'community/webkit2gtk/APKBUILD')
-rw-r--r--community/webkit2gtk/APKBUILD36
1 files changed, 19 insertions, 17 deletions
diff --git a/community/webkit2gtk/APKBUILD b/community/webkit2gtk/APKBUILD
index b8a4de2481c..af0f381fafb 100644
--- a/community/webkit2gtk/APKBUILD
+++ b/community/webkit2gtk/APKBUILD
@@ -3,12 +3,13 @@
# Maintainer: Jiri Horner <laeqten@gmail.com>
pkgname=webkit2gtk
pkgver=2.20.3
-pkgrel=0
-pkgdesc="portable web rendering engine WebKit for GTK+"
+pkgrel=1
+pkgdesc="Portable web rendering engine WebKit for GTK+"
url="https://webkitgtk.org/"
arch="all"
-license="LGPL-2.0-or-later BSD"
-makedepends="$depends_dev
+license="LGPL-2.0-or-later BSD-2-Clause"
+options="!check" # 2.20.3-r1 no idea why gtest is removed in prepare
+makedepends="
bison
cmake
enchant-dev
@@ -46,6 +47,7 @@ source="https://webkitgtk.org/releases/webkitgtk-$pkgver.tar.xz
fix_armv6l.patch
musl-fix-javascriptcore.patch
"
+builddir="$srcdir/webkitgtk-$pkgver"
# secfixes:
# 2.18.4-r0:
@@ -68,24 +70,24 @@ source="https://webkitgtk.org/releases/webkitgtk-$pkgver.tar.xz
# - CVE-2017-2371
# - CVE-2017-2373
-
-builddir="${srcdir}/webkitgtk-${pkgver}"
prepare() {
- default_prepare || return 1
- rm -r Source/ThirdParty/gtest/ || return 1
+ default_prepare
+ cd "$builddir"
+ rm -r Source/ThirdParty/gtest/
}
build() {
local _archopt=
case "$CARCH" in
- armhf) _archopt="-DUSE_LD_GOLD=OFF -DENABLE_JIT=OFF -DUSE_SYSMEM_MALLOC=ON";;
- aarch64) _archopt="-DUSE_LD_GOLD=OFF";;
- ppc64le) _archopt="-DENABLE_JIT=OFF -DUSE_SYSMTE_MALLOC=ON";;
- s390x) _archopt="-DUSE_LD_GOLD=OFF -DENABLE_JIT=OFF -DUSE_SYSMEM_MALLOC=ON";;
+ armhf) _archopt="-DUSE_LD_GOLD=OFF -DENABLE_JIT=OFF -DUSE_SYSMEM_MALLOC=ON";;
+ aarch64) _archopt="-DUSE_LD_GOLD=OFF";;
+ ppc64le) _archopt="-DENABLE_JIT=OFF -DUSE_SYSMTE_MALLOC=ON";;
+ s390x) _archopt="-DUSE_LD_GOLD=OFF -DENABLE_JIT=OFF -DUSE_SYSMEM_MALLOC=ON";;
esac
cd "$builddir"
- mkdir build && cd build
+ mkdir build
+ cd build
cmake -DPORT=GTK \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_SKIP_RPATH=ON \
@@ -98,15 +100,15 @@ build() {
-DENABLE_SAMPLING_PROFILER=OFF \
-DUSE_WOFF2=OFF\
$_archopt \
- .. || return 1
- make || return 1
+ ..
+ make
}
package() {
cd "$builddir"/build
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
# needed for JIT
- paxmark -m "$pkgdir"/usr/lib/webkit2gtk-4.0/WebKitWebProcess || return 1
+ paxmark -m "$pkgdir"/usr/lib/webkit2gtk-4.0/WebKitWebProcess
}
sha512sums="69a7b27e294de6fd43240ce1d314cd1ccdbf29674c97967674459fd02720b31fa53e5412efbd93dc1e805d38e38feb7fe9a12cdd9c472471676b8db3c11734de webkitgtk-2.20.3.tar.xz