aboutsummaryrefslogtreecommitdiffstats
path: root/community/whois/APKBUILD
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2016-08-18 20:46:53 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-21 22:24:04 +0200
commit5c9f3ca3e307be53b45beeed2ce1626f38008625 (patch)
tree919836fe454e953f46685adf8228b0401280d4b6 /community/whois/APKBUILD
parent6a00a953ba02bab6440a2c784e7db37c6eaeace1 (diff)
testing/[various]: move to community
albatross-themes apk-post-messages autossh bitcoin btrbk entr ffmpegthumbnailer firejail firetools fwsnort gnome-colors imapsync inetutils-syslogd inotify-tools-inc isync junit ktsuss letsencrypt-nosudo libmbim libndp libqmi libteam mini-sendmail modemmanager namecoin networkmanager nginx-naxsi numix-themes nxapi opencl-headers opencl-icd-loader opus-tools perl-authen-ntlm perl-bit-vector perl-data-uniqid perl-file-copy-recursive perl-getopt-argvfile perl-io-tee perl-iptables-chainmgr perl-iptables-parse perl-module-scandeps perl-par-dist perl-par-packer perl-par perl-uri-escape psad py-crcmod py-graphviz py-lz4 py-opencl py-opengl-accelerate runit secpwgen secure-delete socklog spacefm tinyssh udevil virt-viewer virtualbricks whois wrk xpra zram-init
Diffstat (limited to 'community/whois/APKBUILD')
-rw-r--r--community/whois/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/whois/APKBUILD b/community/whois/APKBUILD
new file mode 100644
index 00000000000..64371caab9f
--- /dev/null
+++ b/community/whois/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
+# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
+pkgname=whois
+pkgver=5.2.12
+pkgrel=1
+pkgdesc="Intelligent WHOIS client by Marco d'Itri"
+url="http://www.linux.it/~md/software/"
+arch="all"
+license="GPL2"
+makedepends="$depends_dev perl libidn-dev gettext-dev"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/rfc1036/$pkgname/archive/v$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$_builddir"
+ make CONFIG_FILE="/etc/whois.conf" \
+ HAVE_LIBIDN=1 HAVE_ICONV=1 \
+ CFLAGS="$CFLAGS -lintl $CXXFLAGS" || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make BASEDIR="$pkgdir" install-whois || return 1
+ install -D -m644 whois.conf "$pkgdir/etc/whois.conf"
+}
+
+md5sums="c7d86f4cdc97f92722b2500bf12aefd1 whois-5.2.12.tar.gz"
+sha256sums="8485aa02909fd6aaa1cfd8b5e63559310879bf8a62793a83c96a4502164b968a whois-5.2.12.tar.gz"
+sha512sums="812ae2a344e5b190175213cca1b10cc58821312f8ad8b31995ecb6963e71b1343ccfa6f06ce896856b9c9622be3dfb22e1fba30ed254f25373f08b4d84143552 whois-5.2.12.tar.gz"