aboutsummaryrefslogtreecommitdiffstats
path: root/community/whois
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2016-09-03 00:23:12 +0000
committerJakub Jirutka <jakub@jirutka.cz>2016-09-03 13:14:30 +0200
commit2379c836b3ad5a41cb86841a6e19c776cf0e5f9c (patch)
tree5f36b1ff644a6ffbff03c41a1dae9a6eebeb3375 /community/whois
parent0b4f85ddb34c5958bbfeba1ba2a492399f03f0b9 (diff)
community/whois: fix undefined libintl
Diffstat (limited to 'community/whois')
-rw-r--r--community/whois/APKBUILD19
-rw-r--r--community/whois/undefined-libintl.patch11
2 files changed, 23 insertions, 7 deletions
diff --git a/community/whois/APKBUILD b/community/whois/APKBUILD
index 8d2b73fde89..831ee21f953 100644
--- a/community/whois/APKBUILD
+++ b/community/whois/APKBUILD
@@ -2,21 +2,23 @@
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=whois
pkgver=5.2.12
-pkgrel=1
+pkgrel=2
pkgdesc="Intelligent WHOIS client by Marco d'Itri"
url="http://www.linux.it/~md/software/"
-arch=""
+arch="all"
license="GPL2"
makedepends="$depends_dev perl libidn-dev gettext-dev"
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/rfc1036/$pkgname/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/rfc1036/$pkgname/archive/v$pkgver.tar.gz
+ undefined-libintl.patch
+ "
_builddir="$srcdir"/$pkgname-$pkgver
build() {
cd "$_builddir"
make CONFIG_FILE="/etc/whois.conf" \
HAVE_LIBIDN=1 HAVE_ICONV=1 \
- CFLAGS="$CFLAGS -lintl $CXXFLAGS" || return 1
+ || return 1
}
package() {
@@ -25,6 +27,9 @@ package() {
install -D -m644 whois.conf "$pkgdir/etc/whois.conf"
}
-md5sums="c7d86f4cdc97f92722b2500bf12aefd1 whois-5.2.12.tar.gz"
-sha256sums="8485aa02909fd6aaa1cfd8b5e63559310879bf8a62793a83c96a4502164b968a whois-5.2.12.tar.gz"
-sha512sums="812ae2a344e5b190175213cca1b10cc58821312f8ad8b31995ecb6963e71b1343ccfa6f06ce896856b9c9622be3dfb22e1fba30ed254f25373f08b4d84143552 whois-5.2.12.tar.gz"
+md5sums="c7d86f4cdc97f92722b2500bf12aefd1 whois-5.2.12.tar.gz
+2242ddc5ddd2bb98465e467e324de686 undefined-libintl.patch"
+sha256sums="8485aa02909fd6aaa1cfd8b5e63559310879bf8a62793a83c96a4502164b968a whois-5.2.12.tar.gz
+27876ce871f1116b6bc5baeab5176787b36c5ca1574dff2267b236f97b2a35d4 undefined-libintl.patch"
+sha512sums="812ae2a344e5b190175213cca1b10cc58821312f8ad8b31995ecb6963e71b1343ccfa6f06ce896856b9c9622be3dfb22e1fba30ed254f25373f08b4d84143552 whois-5.2.12.tar.gz
+83de8846813ee25acda5027a79b71932cdd8d9a13acac6f7d7831c1f84b154fb865abda510d82222e6edb344dead7f480734b1fe83dc3ba8a3ec81b35ba0ab69 undefined-libintl.patch"
diff --git a/community/whois/undefined-libintl.patch b/community/whois/undefined-libintl.patch
new file mode 100644
index 00000000000..0150053a655
--- /dev/null
+++ b/community/whois/undefined-libintl.patch
@@ -0,0 +1,11 @@
+--- whois-5.2.12/Makefile
++++ whois-5.2.12/Makefile.new
+@@ -14,7 +14,7 @@
+
+ # FreeBSD
+ #whois_LDADD += -liconv
+-#LIBS += -L/usr/local/lib -lintl
++LIBS += -lintl
+ #INCLUDES += -I/usr/local/include
+
+ # OS/2 EMX