aboutsummaryrefslogtreecommitdiffstats
path: root/community/wlc
diff options
context:
space:
mode:
authorDaniel Sabogal <dsabogalcc@gmail.com>2017-03-08 19:47:52 -0500
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-03-10 09:34:29 +0000
commit23182897c95a6f08a21268ad782e0bbee2b2a86d (patch)
tree157110f665589a1ae66d7ceed0a89af8b3913906 /community/wlc
parent174ef2bffbd8017a1fb781ac2cf2b576ca564303 (diff)
community/libinput, wayland-protocols, wlc, sway: move from testing
Diffstat (limited to 'community/wlc')
-rw-r--r--community/wlc/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/community/wlc/APKBUILD b/community/wlc/APKBUILD
new file mode 100644
index 00000000000..34158ba4545
--- /dev/null
+++ b/community/wlc/APKBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Daniel Sabogal <dsabogalcc@gmail.com>
+pkgname=wlc
+pkgver=0.0.8
+pkgrel=1
+pkgdesc="Wayland Compositor Library"
+url="https://github.com/Cloudef/wlc"
+arch="all"
+license="MIT"
+depends="xkeyboard-config"
+makedepends="cmake eudev-dev libinput-dev libx11-dev libxkbcommon-dev mesa-dev
+ pixman-dev wayland-dev wayland-protocols xcb-util-image-dev
+ xcb-util-wm-dev"
+subpackages="$pkgname-dev"
+source="https://github.com/Cloudef/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.bz2"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ cmake . \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_SYSCONFDIR=/etc \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ || return 1
+ make
+}
+
+check() {
+ make test -C "$builddir"
+}
+
+package() {
+ make DESTDIR="$pkgdir/" -C "$builddir" install
+}
+
+sha512sums="5ddf7dfc5115fa51ea078933b60c6e8ef9515db98f1c47d4ecfe3f49e07dbdadf2bbeb6f6002cc83d13098dee5fa7e66fcae211a58bd762ee984088aebadb779 wlc-0.0.8.tar.bz2"