aboutsummaryrefslogtreecommitdiffstats
path: root/community/wrk
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2017-11-13 21:08:53 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-11-15 07:52:53 +0000
commit7d4e274927010e16c0d8a14d0502a1faea25ed5a (patch)
tree2bfaf7f7eb34091e5a2fd90c0b119181152df6aa /community/wrk
parent4766696f3e5e196e7c9c9ab7de42a4da87aa8c27 (diff)
community/wrk: upgrade to 4.0.2
https://github.com/wg/wrk/blob/master/CHANGES
Diffstat (limited to 'community/wrk')
-rw-r--r--community/wrk/APKBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/community/wrk/APKBUILD b/community/wrk/APKBUILD
index edcc94e6940..cd570470305 100644
--- a/community/wrk/APKBUILD
+++ b/community/wrk/APKBUILD
@@ -2,8 +2,8 @@
# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=wrk
-pkgver=4.0.1
-pkgrel=3
+pkgver=4.0.2
+pkgrel=0
pkgdesc="wrk is a modern HTTP benchmarking tool"
url="https://github.com/wg/wrk"
# requires -march=i586 to build on x86
@@ -11,18 +11,21 @@ arch="x86_64"
license="ASL 2.0"
depends=""
depends_dev=""
-makedepends="libressl-dev"
-install=""
+options="!check"
+makedepends="libressl-dev perl-dev"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/wg/wrk/archive/$pkgver.tar.gz"
+builddir="$srcdir"/$pkgname-$pkgver
-_builddir="$srcdir"/$pkgname-$pkgver
build() {
- make -C "$_builddir" || return 1
+ cd "$builddir"
+ # see https://github.com/wg/wrk/issues/310
+ touch buildinf.h
+ make -j1 -C "$builddir"
}
package() {
- cd "$_builddir"
+ cd "$builddir"
mkdir -p $pkgdir/usr/bin
mkdir -p $pkgdir/usr/share/doc/$pkgname/scripts
install -m755 -D $pkgname "$pkgdir"/usr/bin/$pkgname
@@ -32,6 +35,4 @@ package() {
install -m755 -D scripts/* "$pkgdir"/usr/share/doc/$pkgname/scripts/
}
-md5sums="2520c55f197b5bb38b96ef2495b9af11 wrk-4.0.1.tar.gz"
-sha256sums="c03bbc283836cb4b706eb6bfd18e724a8ce475e2c16154c13c6323a845b4327d wrk-4.0.1.tar.gz"
-sha512sums="75e8e0d6f1e7929a43bb80fe65e1f2a36a169d19d839940ebe7dc9765a182e1adee3ba2873e97511ddabbd252b8447a69a92a2cfc584f05d65a2f8b31bbf4141 wrk-4.0.1.tar.gz"
+sha512sums="4279cf7136e2919779be3f61f462136a7a5288eac481104b844193682a8fc554581fd3942624d0be9317a3e82c82497927a124b9b4dbdf455e30d3f0cad1fdea wrk-4.0.2.tar.gz"