aboutsummaryrefslogtreecommitdiffstats
path: root/community/xdg-utils/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-02-24 19:05:37 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-02-24 23:56:43 -0300
commit8940c306d543f11669616a10c1f7ff3c2ac81da7 (patch)
tree24866a8f5f16f3894d5a7b2590e8ab1a9daea260 /community/xdg-utils/APKBUILD
parenta75c6134406aa803087b3ea7a66f0d6ffc262a0c (diff)
community/xdg-utils: move from main
Diffstat (limited to 'community/xdg-utils/APKBUILD')
-rw-r--r--community/xdg-utils/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/community/xdg-utils/APKBUILD b/community/xdg-utils/APKBUILD
new file mode 100644
index 00000000000..53420f94889
--- /dev/null
+++ b/community/xdg-utils/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xdg-utils
+pkgver=1.1.3
+pkgrel=0
+pkgdesc="Basic desktop integration functions"
+url="https://portland.freedesktop.org/wiki"
+arch="noarch"
+options="!check" # No test suite.
+license="MIT"
+depends="xset xprop"
+makedepends="libxml2-utils libxslt xmlto lynx"
+subpackages="$pkgname-doc"
+source="https://portland.freedesktop.org/download/$pkgname-$pkgver.tar.gz
+ xdg-screensaver-mv-T.patch
+ "
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="d1f819a211eb4104a90dfdc6fedcb640fd46b15ccfc8762266f8f538c49d74cb00027b8c1af991fb2a200acb4379986ae375700e06a2aa08fb41a38f883acb3e xdg-utils-1.1.3.tar.gz
+db0896979fbc3b575826b4d732658564d08bcfc957b3fa1490fe02e4cc7b52adfa1e05956432a732dae8f50145e0040bc145739ba5692ae1b86fa74be8174436 xdg-screensaver-mv-T.patch"