aboutsummaryrefslogtreecommitdiffstats
path: root/community/xeyes/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-16 00:07:34 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-16 00:07:34 +0000
commit0e840e67bd11f3ed927c84cf79ec4ec0a0928e65 (patch)
treeb2e1d4fe8c6b2d0e363c7930868aa7ce8ae1ef38 /community/xeyes/APKBUILD
parentd9740c715f71dbb5f069740ac13ce8d6af5ed9e1 (diff)
community/xeyes: build fix aarch64
Diffstat (limited to 'community/xeyes/APKBUILD')
-rw-r--r--community/xeyes/APKBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/community/xeyes/APKBUILD b/community/xeyes/APKBUILD
index 51128ffabdd..b43ff3476bc 100644
--- a/community/xeyes/APKBUILD
+++ b/community/xeyes/APKBUILD
@@ -14,10 +14,15 @@ install=""
subpackages="$pkgname-doc"
source="http://www.x.org/releases/individual/app/${pkgname}-${pkgver}.tar.bz2"
-_builddir="$srcdir/$pkgname-$pkgver"
+builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ default_prepare || return 1
+ update_config_guess || return 1
+}
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--prefix=/usr \
--datarootdir=/usr/share \
@@ -26,7 +31,7 @@ build() {
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
}