aboutsummaryrefslogtreecommitdiffstats
path: root/community/xf86-video-sis/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-10-22 06:12:39 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-11-30 17:14:33 +0000
commit7ecba75ca817102b18a7b147b6e42336eb938390 (patch)
treee1ad884ece12bf6fb6939a2d91351f60ed7f20ad /community/xf86-video-sis/APKBUILD
parent754da2a633edce5f4989e39224131d413181b9e4 (diff)
community/xf86-video-sis: move from main
Diffstat (limited to 'community/xf86-video-sis/APKBUILD')
-rw-r--r--community/xf86-video-sis/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/xf86-video-sis/APKBUILD b/community/xf86-video-sis/APKBUILD
new file mode 100644
index 00000000000..2eb83ce5cdd
--- /dev/null
+++ b/community/xf86-video-sis/APKBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xf86-video-sis
+pkgver=0.12.0
+pkgrel=0
+pkgdesc="X.org SiS video driver"
+url="https://xorg.freedesktop.org"
+arch="all"
+license="MIT"
+subpackages="$pkgname-doc"
+makedepends="xorg-server-dev util-macros mesa-dev libxi-dev xorgproto"
+source="https://www.x.org/releases/individual/driver/xf86-video-sis-$pkgver.tar.bz2
+ fix-old-cpp-macros.patch
+ "
+
+build() {
+ export LDFLAGS="$LDFLAGS -Wl,-z,lazy"
+
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+}
+sha512sums="5aa101e5217f15667f2c94f7a76f4afcf47717b61f5d206ce65efe35dc3f674ca294f98ca8586971c6467f31decdd94d8255ebfc7dc220fac0179afc61995952 xf86-video-sis-0.12.0.tar.bz2
+d4262ac8c17d04547473df260518247afb09a5bf6ddbe85d7877534f1e99d316d52fb933839f56a4e61b3706b124fa91c6926d432ba542e525f2007af253ff2a fix-old-cpp-macros.patch"