aboutsummaryrefslogtreecommitdiffstats
path: root/community/xhost/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-02-24 18:44:52 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-02-24 23:29:30 -0300
commit03602cbbcbb2b8ec2727beb9f1dceb8c987486bd (patch)
tree46a3051f9a7afb874e9b93149f0592d39e939934 /community/xhost/APKBUILD
parentf0972b33c06b79f907d86fdbe10585042279d321 (diff)
community/xhost: move from main
Diffstat (limited to 'community/xhost/APKBUILD')
-rw-r--r--community/xhost/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/xhost/APKBUILD b/community/xhost/APKBUILD
new file mode 100644
index 00000000000..4154ff12abe
--- /dev/null
+++ b/community/xhost/APKBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xhost
+pkgver=1.0.8
+pkgrel=0
+pkgdesc="Controls host and/or user access to a running X server"
+url="http://xorg.freedesktop.org/"
+arch="all"
+license="MIT"
+subpackages="$pkgname-doc"
+depends=
+makedepends="libx11-dev libxmu-dev libxau-dev util-macros"
+source="https://www.x.org/releases/individual/app/$pkgname-$pkgver.tar.bz2"
+
+builddir="$srcdir/$pkgname-$pkgver"
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --mandir=/usr/share/man
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="55581f9bc45a70a73b13fe718ca83c4cb0a6116d26addc0f07659ebeb5bf7d2379e84cab5a1702ae77a298a66f42ae03f41ddc7d5acd61c6f18448e58ad7cb6b xhost-1.0.8.tar.bz2"