aboutsummaryrefslogtreecommitdiffstats
path: root/community/xkill
diff options
context:
space:
mode:
authorScrumpyJack <scrumpyjack@st.ilet.to>2016-06-27 10:17:05 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2016-07-04 11:42:28 +0200
commit2ff62bbb9f7b2c82a826d7b159c1bc482aa8f0bd (patch)
tree97c60fb3221dfe78cd7ccfda5db6125c81d5f676 /community/xkill
parent00e8ff605f1c4f6386596f35f2a5287ff9b8bc55 (diff)
testing/[various]: move packages to community
Moves the packages listed below from the testing to the community repository after successfully testing of said packages. asciinema at calcurse cmus compton cpio dvd+rw-tools fortune fvwm geary h2o heirloom-mailx leafpad nedit nmh rover tor torsocks urlview vdesk w3m wbar xcalc xclock xeyes xkill
Diffstat (limited to 'community/xkill')
-rw-r--r--community/xkill/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/community/xkill/APKBUILD b/community/xkill/APKBUILD
new file mode 100644
index 00000000000..79d8bbe2a6c
--- /dev/null
+++ b/community/xkill/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: ScrumpyJack <scrumpyjack@st.ilet.to>
+# Maintainer: ScrumpyJack <scrumpyjack@st.ilet.to>
+pkgname=xkill
+pkgver=1.0.4
+pkgrel=0
+pkgdesc="Kill tool for the X Window System"
+url="http://www.x.org"
+arch="all"
+license="MIT"
+depends=""
+depends_dev=""
+makedepends="libx11-dev libxmu-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://www.x.org/releases/individual/app/${pkgname}-${pkgver}.tar.bz2"
+
+_builddir="${srcdir}/${pkgname}-${pkgver}"
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --datarootdir=/usr/share \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="0ae6bc2a8d3af68e9c76b1a6ca5f7a78 xkill-1.0.4.tar.bz2"
+sha256sums="88ef2a304f32f24b255e879f03c1dcd3a2be3e71d5562205414f267d919f812e xkill-1.0.4.tar.bz2"
+sha512sums="14d1fc0eff96a62d66307f09efc599639ee70be4bf580e2857569326881bfdcae7a8a21640509875218dd2b88575b4801ab0c43c4295550dc71141a579483545 xkill-1.0.4.tar.bz2"