aboutsummaryrefslogtreecommitdiffstats
path: root/community/xxhash
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-10-11 09:59:34 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-10-11 17:11:09 -0300
commit3afc772e78986a879be5ba7e6321fbc9c9d4687c (patch)
tree77c37a668cb7b7d4e75ff34c1aae9221f0d6848a /community/xxhash
parentf39cb39781a53c8137cd7f616559d10a28e4cf4a (diff)
community/xxhash: upgrade to 0.7.2
Diffstat (limited to 'community/xxhash')
-rw-r--r--community/xxhash/APKBUILD12
-rw-r--r--community/xxhash/lift-XXH_FORCE_MEMORY_ACCESS-condition.patch14
2 files changed, 5 insertions, 21 deletions
diff --git a/community/xxhash/APKBUILD b/community/xxhash/APKBUILD
index a5e1bfc7036..def3d6e902c 100644
--- a/community/xxhash/APKBUILD
+++ b/community/xxhash/APKBUILD
@@ -3,19 +3,18 @@
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=xxhash
_pkgname=xxHash
-pkgver=0.7.1
+pkgver=0.7.2
_pypkg=python-xxhash
-_pyver=1.3.0
+_pyver=1.4.1
pkgrel=0
pkgdesc="Extremely fast non-cryptographic hash algorithm"
-url="http://www.xxhash.com"
+url="https://cyan4973.github.io/xxHash/"
arch="all"
license="BSD-2-Clause GPL-2.0-or-later"
makedepends="python3-dev py3-setuptools"
subpackages="$pkgname-dev $pkgname-doc py3-$pkgname:_py3 lib$pkgname:libs"
source="$_pkgname-$pkgver.tar.gz::https://github.com/Cyan4973/$_pkgname/archive/v$pkgver.tar.gz
$_pypkg-$_pyver.tar.gz::https://github.com/ifduyue/$_pypkg/archive/v$_pyver.tar.gz
- lift-XXH_FORCE_MEMORY_ACCESS-condition.patch
"
builddir="$srcdir/"$_pkgname-$pkgver
_pybuilddir="$srcdir/"$_pypkg-$_pyver
@@ -60,6 +59,5 @@ _py3() {
python3 setup.py install --prefix=/usr --root="$subpkgdir"
}
-sha512sums="03aa89c35fffafa8fc81b249ff4fa0dd3f7985466106815a9f36b00314ce82e3e2586e7abec5b56dd94d9b785768ac9562b03973817390b716cad8cd53e9ebc1 xxHash-0.7.1.tar.gz
-4aafc2c9f9eac13e6bae11c49ab2342754c2afebe9b2430945ab32e56cc651b4cbbc08fdc2caf339aafb971a1ae3cd76b1983c8780f3b4f9df64a7e19e3927ea python-xxhash-1.3.0.tar.gz
-5503fc4177bbbc8ebac3c921be1a560b7197d1e66cb94064013fa5df750c6659520bb8ddec689b2b3ccb51cec3088508c7dce4bc2cf8c6127053d96e39cd7e6e lift-XXH_FORCE_MEMORY_ACCESS-condition.patch"
+sha512sums="90d4e7422729441e5013928b306fd6f394ab6f97628ec88369fbb33891c9a2cfae495516d8dd0741eda9c38859132b1bd78f2c7b8dae1dce80eeca8ea5cba575 xxHash-0.7.2.tar.gz
+42a333a59cea01f11f13dec1c760759c9b8a32b3029f81d533715cc86e3cf5d0f59e0e4698cdadf5a110baebdc79bd30d0bea81891b193d5a80b9de7b2c4a77b python-xxhash-1.4.1.tar.gz"
diff --git a/community/xxhash/lift-XXH_FORCE_MEMORY_ACCESS-condition.patch b/community/xxhash/lift-XXH_FORCE_MEMORY_ACCESS-condition.patch
deleted file mode 100644
index 581a44777ef..00000000000
--- a/community/xxhash/lift-XXH_FORCE_MEMORY_ACCESS-condition.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- a/xxhash.c
-+++ b/xxhash.c
-@@ -54,10 +54,7 @@
- || defined(__ARM_ARCH_6K__) || defined(__ARM_ARCH_6Z__) \
- || defined(__ARM_ARCH_6ZK__) || defined(__ARM_ARCH_6T2__) )
- # define XXH_FORCE_MEMORY_ACCESS 2
--# elif (defined(__INTEL_COMPILER) && !defined(_WIN32)) || \
-- (defined(__GNUC__) && ( defined(__ARM_ARCH_7__) || defined(__ARM_ARCH_7A__) \
-- || defined(__ARM_ARCH_7R__) || defined(__ARM_ARCH_7M__) \
-- || defined(__ARM_ARCH_7S__) ))
-+# elif (defined(__INTEL_COMPILER) && !defined(_WIN32)) || defined(__GNUC__)
- # define XXH_FORCE_MEMORY_ACCESS 1
- # endif
- #endif