aboutsummaryrefslogtreecommitdiffstats
path: root/community/yarn
diff options
context:
space:
mode:
authorEd Robinson <ed.robinson@reevoo.com>2017-04-19 13:57:16 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-04-21 01:52:15 +0200
commit3cfff27a63302cbcfe29d20f7bf0fa078e488a66 (patch)
tree0be3b4a7bebe50845c126303231e39ff4920ec52 /community/yarn
parent3bce8f6bae91e07093fd7311601abc61fcce599a (diff)
community/yarn: upgrade to 0.23.2
Diffstat (limited to 'community/yarn')
-rw-r--r--community/yarn/APKBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/community/yarn/APKBUILD b/community/yarn/APKBUILD
index 1616127b5fa..787bd9ed0e0 100644
--- a/community/yarn/APKBUILD
+++ b/community/yarn/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Ed Robinson <ed@reevoo.com>
# Maintainer: Ed Robinson <ed@reevoo.com>
pkgname=yarn
-pkgver=0.22.0
+pkgver=0.23.2
pkgrel=0
pkgdesc="Fast, reliable, and secure dependency management for Node.js"
url="https://yarnpkg.com/"
@@ -19,9 +19,6 @@ prepare() {
cd "$builddir"
- # These tests runs only on Ubuntu, so delete them.
- rm -r end_to_end_tests
-
# Remove support for legacy nodejs.
rm -r lib-legacy
@@ -29,13 +26,14 @@ prepare() {
# Node does not load *.min.js files, so these are useless for us.
# We respect licenses, but really don't wanna waste disk space (~1 MiB)
# with dozens copies of the same files.
- rm yarn.lock
+ rm yarn.lock jenkins_jobs.groovy
find . \( -iname '*.md' \
-o -iname '*.md~' \
-o -iname '*.cmd' \
-o -name '*.min.js' \
-o -name '*.map' \
-o -name 'bower.json' \
+ -o -name 'Dockerfile.*' \
-o -name 'Gruntfile.js' \
-o -iname 'license*' -a ! -name '*.js' \
-o -type f -a -name '.*' \) \
@@ -53,6 +51,6 @@ package() {
ln -s /$destdir/bin/yarn "$pkgdir"/usr/bin/yarnpkg
}
-sha512sums="56fbadf0dcd077bde75e8e3103c07a3c6d5129b9d8a3ae3b46f8e0f6b149c5e339f435af315b6c52f8415fdaadb60ae8d6be63f8c0f24409145aed21611e1d41 yarn-v0.22.0.tar.gz
+sha512sums="eae2143a5cd7108e7abf1a6888923d5eacb3dfca64d5bdb0131821b46b447d9ec157a088a7b762f7a61c038b3b423a6b99b0c068dd3ec7277984a355e57e21b1 yarn-v0.23.2.tar.gz
30431f7aa5fe7382e062b92e413ea8d118e157d89aa043353c18ff7d1721d0e3ecfbe68de1f0058b3b70cee5cf9baa08d28f1718beb5d14fcb0cf2881dff1eac apk-install-method.patch
b1d0f8e4bee9fb73002f7dbe7cdc5cafdb5bac53e4649bd9d98dbce9afb7950bafd392a4b8433d76aa90f931c2f92972b8ae41fe61f506690439d5959b6c09d5 remove-support-for-legacy-nodejs.patch"