aboutsummaryrefslogtreecommitdiffstats
path: root/community/z3
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2020-02-21 23:56:36 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2020-02-22 00:12:38 +0100
commitafd9ecdf23d26aaf846eb7fce132fbda98f82cf3 (patch)
treed6a6e8421d243ce9eef86078adc585bcc728f644 /community/z3
parentbc29e069da166db4b6520a42f14d555798304ec3 (diff)
community/z3: fix build with None build type
Diffstat (limited to 'community/z3')
-rw-r--r--community/z3/APKBUILD6
-rw-r--r--community/z3/none-build-type.patch17
2 files changed, 21 insertions, 2 deletions
diff --git a/community/z3/APKBUILD b/community/z3/APKBUILD
index ec32205dea8..ae39f5708d8 100644
--- a/community/z3/APKBUILD
+++ b/community/z3/APKBUILD
@@ -10,7 +10,8 @@ license="MIT"
makedepends="cmake python3"
subpackages="$pkgname-dev py3-$pkgname:py3:noarch"
source="https://github.com/Z3Prover/z3/archive/z3-$pkgver.tar.gz
- 0001-Fix-fail-to-build-on-clang-and-g.patch"
+ 0001-Fix-fail-to-build-on-clang-and-g.patch
+ none-build-type.patch"
builddir="$srcdir/z3-z3-$pkgver"
build() {
@@ -51,4 +52,5 @@ py3() {
}
sha512sums="145e2b2f1fa4edd0917107c7e1d54d779c7ed85c48af2ce6def4c90d1c4db05f74c9657e173cedf48770589fbe484c97fa1923295271cd3792523ffc4f67ed0c z3-4.8.7.tar.gz
-4463b00e84d81447e62f6363163e6a2fa072fe1a1e1bab29c966ae00a222ab1a2e7429b6527bc5d81defb376590dca7bbc06b970fa780d77384011b573ffd7fd 0001-Fix-fail-to-build-on-clang-and-g.patch"
+4463b00e84d81447e62f6363163e6a2fa072fe1a1e1bab29c966ae00a222ab1a2e7429b6527bc5d81defb376590dca7bbc06b970fa780d77384011b573ffd7fd 0001-Fix-fail-to-build-on-clang-and-g.patch
+9a99777d29558ffcc15fa43e3dc1da46261469c60561c5bc3bcaab40164ed59c45386ed597f27c8160e69acf16d0d8f3ddb06a53b52886ab146d54becc9ccb02 none-build-type.patch"
diff --git a/community/z3/none-build-type.patch b/community/z3/none-build-type.patch
new file mode 100644
index 00000000000..06e5164ff94
--- /dev/null
+++ b/community/z3/none-build-type.patch
@@ -0,0 +1,17 @@
+The build system includes its one check for available CMake build types.
+This check is incorrect as it doesn't include the None build type.
+
+See: https://github.com/Z3Prover/z3/issues/3071
+
+diff -upr z3-z3-4.8.7.orig/CMakeLists.txt z3-z3-4.8.7/CMakeLists.txt
+--- z3-z3-4.8.7.orig/CMakeLists.txt 2020-02-21 23:54:37.917997553 +0100
++++ z3-z3-4.8.7/CMakeLists.txt 2020-02-21 23:55:22.061925859 +0100
+@@ -129,7 +129,7 @@ set(Z3_DEPENDENT_EXTRA_CXX_LINK_FLAGS ""
+ # Build type
+ ################################################################################
+ message(STATUS "CMake generator: ${CMAKE_GENERATOR}")
+-set(available_build_types Debug Release RelWithDebInfo MinSizeRel)
++set(available_build_types None Debug Release RelWithDebInfo MinSizeRel)
+ if (DEFINED CMAKE_CONFIGURATION_TYPES)
+ # Multi-configuration build (e.g. Visual Studio and Xcode). Here
+ # CMAKE_BUILD_TYPE doesn't matter