aboutsummaryrefslogtreecommitdiffstats
path: root/community/zstd
diff options
context:
space:
mode:
authorAndré Klitzing <aklitzing@gmail.com>2017-08-23 13:11:34 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2017-08-24 23:20:41 +0000
commit6ea9289d7063c800011ee9f6e2c920831a2af7be (patch)
treea471fd11e6fc15de6955d51354467aafddc3665f /community/zstd
parent5ba3c024a3f5c452dd7cbf849e5c7bcdaf3e78e4 (diff)
community/zstd: upgrade to 1.3.1
Diffstat (limited to 'community/zstd')
-rw-r--r--community/zstd/APKBUILD9
-rw-r--r--community/zstd/increase-max-number-cores-supported.patch11
2 files changed, 3 insertions, 17 deletions
diff --git a/community/zstd/APKBUILD b/community/zstd/APKBUILD
index e02526461d5..699ec3069d4 100644
--- a/community/zstd/APKBUILD
+++ b/community/zstd/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: stef <l0ls0fo2i@ctrlc.hu>
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=zstd
-pkgver=1.3.0
+pkgver=1.3.1
pkgrel=0
pkgdesc="Zstandard - Fast real-time compression algorithm"
url="http://www.zstd.net"
@@ -9,9 +9,7 @@ arch="all !armhf"
license="BSD"
checkdepends="file"
subpackages="$pkgname-dev $pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/facebook/$pkgname/archive/v$pkgver.tar.gz
- increase-max-number-cores-supported.patch"
-
+source="$pkgname-$pkgver.tar.gz::https://github.com/facebook/$pkgname/archive/v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
build() {
@@ -29,5 +27,4 @@ package() {
make PREFIX="/usr" DESTDIR="$pkgdir" install
}
-sha512sums="5eb9e001e14d3342e76eb57b672c636fd56839ba8fc0ba9a751484ea93389c72c494ad2125dc2f9be1f72481f3af34568477123f7e9d3c7504e061e4c083cb30 zstd-1.3.0.tar.gz
-b764be95a7b3876b62215ff4feb8c464e9cbf467e410de4e7026e8d10f6287193d16ae76d516f3a2eaa7c526d3a73df1437041930896dd8a29dc91b988d10fcb increase-max-number-cores-supported.patch"
+sha512sums="cc2ace7b2dd19a2bbf4c43a89d64a7ce121309f712bfb4940ccfd6f9353f1466612ef7096adcd852f54eaea8663d884acf681c83ae5b274b24c9b85f21367b7c zstd-1.3.1.tar.gz"
diff --git a/community/zstd/increase-max-number-cores-supported.patch b/community/zstd/increase-max-number-cores-supported.patch
deleted file mode 100644
index 34c1590206c..00000000000
--- a/community/zstd/increase-max-number-cores-supported.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- zstd-1.3.0/lib/compress/zstdmt_compress.c
-+++ zstd-1.3.0/lib/compress/zstdmt_compress.c
-@@ -9,7 +9,7 @@
-
-
- /* ====== Tuning parameters ====== */
--#define ZSTDMT_NBTHREADS_MAX 128
-+#define ZSTDMT_NBTHREADS_MAX 256
-
-
- /* ====== Compiler specifics ====== */