aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-11-20 11:00:45 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-20 11:03:09 +0100
commitb28198b4cdfcf5e954988b1fcdb9ffa967d8dea8 (patch)
tree6f43d1b4e924c260667482ff67d1bcea19e6c530 /community
parent6b738a488f519bb5ea7afd63fa8a42fd234418df (diff)
community/libgweather: fix tests
Diffstat (limited to 'community')
-rw-r--r--community/libgweather/APKBUILD7
-rw-r--r--community/libgweather/fix-test.patch28
2 files changed, 33 insertions, 2 deletions
diff --git a/community/libgweather/APKBUILD b/community/libgweather/APKBUILD
index 739a8dc53a4..41566d12dee 100644
--- a/community/libgweather/APKBUILD
+++ b/community/libgweather/APKBUILD
@@ -13,7 +13,9 @@ makedepends="gtk+3.0-dev libsoup-dev libxml2-dev vala
glib-dev geocode-glib-dev gobject-introspection-dev
libxml2-utils gtk-doc py-six glade-dev meson ninja"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-source="https://download.gnome.org/sources/libgweather/${pkgver%.*}/libgweather-$pkgver.tar.xz"
+source="https://download.gnome.org/sources/libgweather/${pkgver%.*}/libgweather-$pkgver.tar.xz
+ fix-test.patch
+ "
build() {
meson \
@@ -35,4 +37,5 @@ package() {
DESTDIR="$pkgdir" ninja -C output install
}
-sha512sums="44451837039965251d86f6f538c943a771ab1944d9190ddb2c6bdb34b3ed0e33756c537e84f24487fd5f28b107e8d3af05a6c20a68f83734ac26ff69a8bd0aba libgweather-3.34.0.tar.xz"
+sha512sums="44451837039965251d86f6f538c943a771ab1944d9190ddb2c6bdb34b3ed0e33756c537e84f24487fd5f28b107e8d3af05a6c20a68f83734ac26ff69a8bd0aba libgweather-3.34.0.tar.xz
+ad9e4bf0d7cc12dfab6ed2870c4f7d52f78b04eaa3cd440f8f85da67106060854364f213d2052ce77158ac2e54be9e33a206bf1dfb634a9bdc17d98505588de7 fix-test.patch"
diff --git a/community/libgweather/fix-test.patch b/community/libgweather/fix-test.patch
new file mode 100644
index 00000000000..47ee7ae42bb
--- /dev/null
+++ b/community/libgweather/fix-test.patch
@@ -0,0 +1,28 @@
+From ee246dc058098dee1709d76635e72db35efcef4e Mon Sep 17 00:00:00 2001
+From: Bastien Nocera <hadess@hadess.net>
+Date: Wed, 20 Nov 2019 10:55:02 +0100
+Subject: [PATCH] tests: Add another duplicate
+
+$ wget -O- -q https://www.aviationweather.gov/docs/metar/stations.txt | grep KX26
+FL SEBASTIAN KX26 X26 27 49N 080 30W 6 X W 8 US
+FL VALKARIA AFS KX26 X26 27 49N 080 30W 6 X 8 US
+---
+ libgweather/test_libgweather.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/libgweather/test_libgweather.c b/libgweather/test_libgweather.c
+index 1bfa3d4..8a21911 100644
+--- a/libgweather/test_libgweather.c
++++ b/libgweather/test_libgweather.c
+@@ -336,6 +336,7 @@ parse_metar_stations (const char *contents)
+ "KHQG",
+ "KOEL",
+ "KTQK",
++ "KX26",
+ NULL
+ };
+ if (g_strv_contains (known_duplicates, station)) {
+--
+2.22.0
+
+