aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-12-23 17:22:06 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-23 22:58:40 +0100
commitd5a7a933ce4765c0657c0522712ebdcfb1b19c01 (patch)
tree53e7ca220a228c80e03e9982a04a9444727de9f2 /community
parent728843a03a77416f3937909892a5486d051d66fa (diff)
community/libwacom: upgrade to 1.2
Diffstat (limited to 'community')
-rw-r--r--community/libwacom/APKBUILD6
-rw-r--r--community/libwacom/disable-tests.patch26
2 files changed, 18 insertions, 14 deletions
diff --git a/community/libwacom/APKBUILD b/community/libwacom/APKBUILD
index f5ed0bb1cbd..1b70d2ffe3c 100644
--- a/community/libwacom/APKBUILD
+++ b/community/libwacom/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Ivan Tham <pickfire@riseup.net>
# Maintainer: Ivan Tham <pickfire@riseup.net>
pkgname=libwacom
-pkgver=1.1
+pkgver=1.2
pkgrel=0
pkgdesc="Library to help implement Wacom tablet settings"
url="https://github.com/linuxwacom/libwacom/wiki"
@@ -29,5 +29,5 @@ package() {
DESTDIR="$pkgdir" ninja -C output install
}
-sha512sums="8b63d9bad18c27f8078711408a7b79c70086cd0c64fe692ee693d53d834dff8ab45631eabd206f0dfac80d8cc86c14b5833831b1b99b06e34aacd235176d266b libwacom-1.1.tar.bz2
-2d15058bc985b3f70dd1784fceefe86bedb50e269b1b981d101d0c284ec1650de7a2f53d0b7474cc719d44aa54c1879b2d0c09ac717f4408c09178b74b7a141e disable-tests.patch"
+sha512sums="595c073d8160bce2d6cec13d5c672594c73ae677e37dbba0ac088c9010d6e2f824d442ccdb7f695642bd06cce75c85473d863823c20a46fbe27e966ae3fed147 libwacom-1.2.tar.bz2
+62f4e02e013a8c1e70bcde9dd9b582461cba9f011cea3fd5b63215a239e0efefe5999f6e7e46b467ebf7402ce613670c37180d89e1fe97bab082706010481e36 disable-tests.patch"
diff --git a/community/libwacom/disable-tests.patch b/community/libwacom/disable-tests.patch
index b1028595827..3ecf9defc89 100644
--- a/community/libwacom/disable-tests.patch
+++ b/community/libwacom/disable-tests.patch
@@ -1,8 +1,8 @@
diff --git a/meson.build b/meson.build
-index 6584c86..9368567 100644
+index 41ea756..43262c7 100644
--- a/meson.build
+++ b/meson.build
-@@ -392,13 +392,6 @@ test('svg-layout-exists',
+@@ -410,13 +410,6 @@ test('svg-layout-exists',
args: [meson.source_root()],
suite: ['all'])
@@ -16,18 +16,22 @@ index 6584c86..9368567 100644
############### tools ###########################
executable('libwacom-list-local-devices',
-@@ -533,13 +526,6 @@ if get_option('tests')
+@@ -552,18 +545,6 @@ if get_option('tests')
message('valgrind not found, disabling valgrind test suite')
endif
-- test_deprecated = executable('test-deprecated',
-- 'test/test-deprecated.c',
-- dependencies: [dep_libwacom, dep_dl],
-- include_directories: [includes_src],
-- c_args: tests_cflags,
-- install: false)
-- test('test-deprecated', test_deprecated, suite: ['all'])
+- # because of the tricks we use in calling the function and exposing
+- # it to begin with, LTO gets confused and this fails to link.
+- # Let's just disable it here.
+- if not get_option('b_lto')
+- test_deprecated = executable('test-deprecated',
+- 'test/test-deprecated.c',
+- dependencies: [dep_libwacom, dep_dl],
+- include_directories: [includes_src],
+- c_args: tests_cflags,
+- install: false)
+- test('test-deprecated', test_deprecated, suite: ['all'])
+- endif
endif
# This is a non-optional test
-