summaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorKaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>2017-07-06 19:00:45 +0300
committerKaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>2017-07-06 19:02:24 +0300
commit70e4c858b97b18a0843073c6bf9ac4fe37ec22ec (patch)
tree35d0c3effbed3a28b47fcde95c76bc8cc87e09e2 /community
parentb89a4bde76f9d025b5d867009cb3cf74d956c3bb (diff)
community/captagent: add missing prepare function
Diffstat (limited to 'community')
-rw-r--r--community/captagent/APKBUILD14
1 files changed, 13 insertions, 1 deletions
diff --git a/community/captagent/APKBUILD b/community/captagent/APKBUILD
index a3bfcb13e85..b1e996b3510 100644
--- a/community/captagent/APKBUILD
+++ b/community/captagent/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
pkgname=captagent
pkgver=6.1.0.20
-pkgrel=3
+pkgrel=4
pkgdesc="HEP Capture Agent for HOMER"
url="https://github.com/sipcapture/captagent"
arch="all"
@@ -14,6 +14,18 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/sipcapture/captagent/archive
ac-fix.patch"
builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ cd "$builddir"
+ for i in $source; do
+ case $i in
+ *.patch)
+ msg "Applying $i"
+ patch -p1 -i "$srcdir"/$i || return 1
+ ;;
+ esac
+ done
+}
+
build() {
cd "$builddir" && ./build.sh && ./configure \
--build=$CBUILD \