aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-10-23 10:14:29 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-10-23 10:18:42 +0000
commit172c0bd3e6c3e2b6dab46dae04008d430f0d44a5 (patch)
treebde35489fe8c6627dfd2ad928a58a26d7ad5b197 /community
parent12d9789f2dde29b5c9b3746ab035bf42f6ba8bb6 (diff)
community/wireshark: security upgrade to 2.4.2
Diffstat (limited to 'community')
-rw-r--r--community/wireshark/APKBUILD34
-rw-r--r--community/wireshark/fix-androiddump.patch11
-rw-r--r--community/wireshark/fix-udpdump.patch13
3 files changed, 37 insertions, 21 deletions
diff --git a/community/wireshark/APKBUILD b/community/wireshark/APKBUILD
index f9a0bb4d42d..3c9a15ff3fb 100644
--- a/community/wireshark/APKBUILD
+++ b/community/wireshark/APKBUILD
@@ -3,7 +3,7 @@
# Contributor: Jeremy Thomerson <jeremy@thomersonfamily.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=wireshark
-pkgver=2.2.8
+pkgver=2.4.2
pkgrel=0
pkgdesc="A network protocol analyzer - GTK version"
url="http://www.wireshark.org"
@@ -14,13 +14,29 @@ makedepends="bison flex perl-dev glib glib-dev libpcap-dev libcap-dev
gtk+3.0-dev c-ares-dev pcre-dev gnutls-dev libgcrypt-dev libressl-dev
libnl3-dev qt5-qtbase-dev qt5-qttools-dev bash"
subpackages="$pkgname-dev $pkgname-doc $pkgname-gtk $pkgname-common tshark"
-source="http://www.wireshark.org/download/src/$pkgname-$pkgver.tar.bz2
- fix-androiddump.patch
+source="http://www.wireshark.org/download/src/$pkgname-$pkgver.tar.xz
+ fix-udpdump.patch
"
builddir="$srcdir"/$pkgname-$pkgver
# secfixes:
+# 2.4.2-r0:
+# - CVE-2017-15191
+# - CVE-2017-15192
+# - CVE-2017-15193
+# 2.4.1-r0:
+# - CVE-2017-13765
+# - CVE-2017-13766
+# - CVE-2017-13767
+# 2.2.10-r0:
+# - CVE-2017-15191
+# - CVE-2017-15192
+# - CVE-2017-15193
+# 2.2.9-r0:
+# - CVE-2017-13765
+# - CVE-2017-13766
+# - CVE-2017-13767
# 2.2.8-r0:
# - CVE-2017-11406
# - CVE-2017-11407
@@ -79,7 +95,9 @@ build() {
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--with-ssl \
- --with-gnutls
+ --with-gnutls \
+ --with-qt=5 \
+ --with-gtk=3
make
}
@@ -116,9 +134,5 @@ gtk() {
mv "$pkgdir"/usr/bin/wireshark-gtk "$subpkgdir"/usr/bin/
}
-md5sums="bb81d0ecf3a8ed46bedfaeae6fd318a8 wireshark-2.2.8.tar.bz2
-38a681230ccab441e64d1fc6f52858c4 fix-androiddump.patch"
-sha256sums="ecf02c148c9ab6e809026ad5743fe9be1739a9840ef6fece6837a7ddfbdf7edc wireshark-2.2.8.tar.bz2
-21aaa55e6b4bb9144146e8e3284512d2c5ee5deee8921b66a513b819b57d8b01 fix-androiddump.patch"
-sha512sums="71af39c8c212bfb78ec978bbeddb4af41aa142643e2a27e05827b3b46d34ff85772321cb63d863270bee75ef6a6eb3e29d0e6052fca6b072f9981ad1eb924c07 wireshark-2.2.8.tar.bz2
-d462e3289c1350a9f712a21d2d1973977e5dd7989f7beff4b71498551174458f572a23f267c83552f088466cb9d2721df2b2eb807514db6ad1e0877dbc87fc6d fix-androiddump.patch"
+sha512sums="212964482a1e45af490ef78b3f2465384f84c007a76c3a99e8de0e2c37d933fb34b0da5631f4a36ca12d2fa7cc4376d3d405cbe7f7113791ea09dba7e5915417 wireshark-2.4.2.tar.xz
+951677dd125b1e36b351cc87a98e8b8d0391d184c7695594dd4270334d86ada1dff5f14cd960da9c5d5d26fc801c42f0219b2db6269f3c526c841c7940d2f369 fix-udpdump.patch"
diff --git a/community/wireshark/fix-androiddump.patch b/community/wireshark/fix-androiddump.patch
deleted file mode 100644
index dbb72b86084..00000000000
--- a/community/wireshark/fix-androiddump.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -ru wireshark-2.2.2.orig/extcap/androiddump.c wireshark-2.2.2/extcap/androiddump.c
---- wireshark-2.2.2.orig/extcap/androiddump.c 2016-11-28 09:55:43.000000000 +0000
-+++ wireshark-2.2.2/extcap/androiddump.c 2016-11-28 09:56:30.683553877 +0000
-@@ -30,6 +30,7 @@
- #include <string.h>
- #include <errno.h>
- #include <time.h>
-+#include <sys/time.h>
-
- #ifdef HAVE_NETINET_IN_H
- # include <netinet/in.h>
diff --git a/community/wireshark/fix-udpdump.patch b/community/wireshark/fix-udpdump.patch
new file mode 100644
index 00000000000..a75a7851ea1
--- /dev/null
+++ b/community/wireshark/fix-udpdump.patch
@@ -0,0 +1,13 @@
+--- a/extcap/udpdump.c
++++ b/extcap/udpdump.c
+@@ -56,6 +56,10 @@
+ #include <wsutil/inet_addr.h>
+ #include <wsutil/filesystem.h>
+
++#ifdef HAVE_SYS_TIME_H
++ #include <sys/time.h>
++#endif
++
+ #define PCAP_SNAPLEN 0xffff
+
+ #define UDPDUMP_DEFAULT_PORT 5555