aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2019-05-03 10:02:42 +0300
committerTimo Teräs <timo.teras@iki.fi>2019-05-03 10:02:42 +0300
commit28651ee815457cdd73c2d1157409a12fd2a3a43c (patch)
treed95d78da204bc0a4a955ddf4cb2d691a28604dc7 /community
parentba0b70fc4c32a54e75beb6266588edd24802ea5d (diff)
community/lua-resty-openidc: backport from edge
Diffstat (limited to 'community')
-rw-r--r--community/lua-resty-openidc/APKBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/community/lua-resty-openidc/APKBUILD b/community/lua-resty-openidc/APKBUILD
new file mode 100644
index 00000000000..26fafb03345
--- /dev/null
+++ b/community/lua-resty-openidc/APKBUILD
@@ -0,0 +1,21 @@
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=lua-resty-openidc
+pkgver=1.7.1
+pkgrel=0
+pkgdesc="OpenID Connect library for the nginx lua module"
+url="https://github.com/zmartzone/$pkgname"
+arch="noarch"
+license="BSD2"
+source="$pkgname-$pkgver.tar.gz::https://github.com/zmartzone/$pkgname/archive/v$pkgver.tar.gz"
+depends="lua-cjson lua-resty-string lua-resty-http lua-resty-session lua-resty-jwt"
+builddir="$srcdir/$pkgname-$pkgver"
+options="!check"
+
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir/usr/share/lua/common"
+ cp -r ./lib/resty "$pkgdir/usr/share/lua/common"
+}
+
+sha512sums="ce52684ebb3a492382e93a71a11c62d1cd17d1a3fd266e7d95453729abeb036ed99fded1a9cee55aec444d7a3e36d7cebd7a537006dff71fafd5dc8aa4c32378 lua-resty-openidc-1.7.1.tar.gz"