aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2018-10-15 10:37:23 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2018-10-15 10:37:23 +0200
commit738f8d0758f2c1ebedd598cbb0a89ecff4f01124 (patch)
tree81d3dba7a9d8e3f4062f0ac2ef7a296c9eef9ee7 /community
parent1d947f4d5b2c6010f3bfb2971c734cfeb73adcfe (diff)
community/monkeysphere: seperate build() and package()
Without this change the sources files are compiled in the package() function as a perquisite of the install target.
Diffstat (limited to 'community')
-rw-r--r--community/monkeysphere/APKBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/community/monkeysphere/APKBUILD b/community/monkeysphere/APKBUILD
index 214baaba24a..aa26b53640a 100644
--- a/community/monkeysphere/APKBUILD
+++ b/community/monkeysphere/APKBUILD
@@ -13,6 +13,11 @@ subpackages="$pkgname-doc"
source="http://archive.monkeysphere.info/debian/pool/$pkgname/m/$pkgname/${pkgname}_$pkgver.orig.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
+build() {
+ cd "$builddir"
+ make
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install